Database error not fixed by reformatting

Note: I’ve already seen several posts about my issue on this forum, but I still have this problem, hence the new thread_._

When I try to boot my Fuze+ into the Sansa firmware, I get an error message saying, “Database error.Please reformat.” It then shuts off immediately. Here is what I tried:

  • Reformat from Linux (the only OS currently accessible to me) using the FAT32 filesystem. Did not resolve the database error.
  • Borrow a Windows laptop and reformat several times using the FAT32 filesystem and with every possible allocation size (including “default allocation size”). Did not resolve the database error.
  • Tried zeroing out the entire storage area then format to FAT32 from Linux. Did not resolve the database error.
  • Tried zeroing out the entire storage area then format to FAT32 using every possible allocation size (including “default allocation size”) using the Windows laptop I borrowed. Did not resolve the database error.
  • Tried updating the firmware. I tried both methods: 1) The firmware update software for Windows, which did not detect the Fuze+, even though Windows itself clearly could detect it since it was able to provide access to the storage area (as drive E:) and the empty uSD slot (as drive F:\ with a message asking me to insert a disk), and 2) The alternate “copy the firmware file to the Fuze+ and boot to the Sansa firmware” method, which did not work since the “display the database error message then shut down” process seems to take priority over updating the firmware.

The strange thing is, Rockbox seems to boot and run just fine on the same Fuze+ that this is occuring on and is perfectly happy to play music in FLAC format non-stop (remember, FLAC is lossless and produces huge files when encoding directly from the CD’s, so it requires quite a bit of reading from the player’s storage), which seems to indicate that the filesystem is not the issue. This is further supported by the fact that both fdisk in Linux and chkdisk in Windows indicate that the filesystem is healthy.

I don’t know what version of the Sansa firmware the Fuze+ has – last time I updated was over a year ago, and I can’t get into the Sansa firmware to check.

If there’s anything else I can try (preferrably from Linux, I have to give the Windows laptop back soon), I’d appreciate the help. Even though I like using Rockbox, I would still prefer having a properly functioning device (or at least, as “properly functioning” as the Fuze+ can possibly be).

I was perusing the forums today and found a post referring to a “recovery mode”, but with no instructions of how to get there. After a quick search, I figured out how (hold Volume Up while plugging in the cable, then wait for the player to be “detected” by the computer). I couldn’t access the Fuze+'s storage, and Sansa Firmware Updater could not detect the player.

I then got the idea to hold Volume Down while plugging in the player since holding Volume Down + Power boots the Sansa firmware, and instead of getting the Rockbox status screen (the one the Rockbox bootloader displays while connected to a computer), I got the Sansa “device connected” screen, and it showed up as an unformatted storage device. I formatted the player using FAT32 and, after unplugging, the Sansa firmware finally worked without giving me the database error! I’ve since updated to the latest Sansa firmware, and reinstalled the Rockbox bootloader.


If you use Rockbox, press the Volume Down button while connecting your Fuze+ to a computer to have the Sansa firmware handle USB functions.

It seems that the Rockbox bootloader reports device layout settings to the computer that the Sansa firmware doesn’t like and the computer will, by default, blindly trust whatever a storage device reports to it since that is normally correct.