Cruzer Pro 4GB fails to load privacy zone

Recently, my Cruzer Pro 4GB has failed to load the privacy zone after successfully entering the pw. Upon initial connect via USB, the device seems healthy. Windows assigns a drive letter and device looks good in Disk Management (38 MB FAT32). Cruzer Pro.exe loads up and I enter the password. Once the password is entered, the error ‘Disk is not formatted’ appears. The error asks me if I want to format the drive which I decline.

After the password is entered successfully into Cruzer Pro.exe, in Disk Management, the unsecured disk partition file system changes from FAT32 to RAW and a 3.68 GB unallocated partition appears. Cruzer Pro.exe can no longer be accessed. If I remove the drive and reattach, the OS sees it as healthy once again and I can access Cruzer Pro.exe. The process just repeats itself. Once the password is reentered, the Disk is not formatted error comes up and the drive becomes totally inaccessible.

I’ve already tried the following in an attempt to get this drive functioning properly.

  • Moved C:\WINDOWS\inf\infcache.1,

  • Deleted related entries in:

HKLM\System\CurrentControlSet\Enum\USB\
HKLM\System\CurrentControlSet\Enum\USBSTOR

Cruzer device has worked normally for quite a while. OS is WinXP SP3.

Would removing items from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR cause this behavior?

Any and all help is appreciated.

it sounds like the private partitio0na is corrupt. Only formatting will fix this. yes the data will be gone and unrecoverable but that is your best chance at fixing the drive. of format fails then it is bad and would need to be replaced. since the password app is launching I would try forgot password and erase option of the software.