Corrupted Files/Folders on 128GB Ultra MicroSD XC Class 1 Card

Hi

I have a SanDisk 128 GB Ultra MicroSD XC Class 1 card that I’ve been using for about a year without any problems, for storing documents and ebooks. I use the card both on my PC (Windows 10) and my Android tablet. On my PC, it is plugged into a USB adapter.

Two days ago, I suddenly got a notification on my PC that ‘There is a problem with this drive. Scan the drive now and fix it.’

  1. The whole microsd card has been scanned with Bitdefender Total Security and is clean.

  2. When I try to transfer files from different directories on the microsd card on to my hard drive, for many of the files I get one of two mesages: ‘Invalid drive’ or ‘File not found’.

  3. I’ve tried plugging the adapter in to all three USB ports on my laptop, but I get the same message.

  4. When in Windows file explorer I select the USB drive and go to TOOLS > Error Checking, it gets about a third of the way through, hangs, and then the Tools Tab Window is frozen on the screen., so that I can’t use file explorer.

  5. When I run Windows chdsk (with ‘r’ parameter to fix files) it gets to 32 percent, hangs a bit , the AutoPlay sound and message appear, and then chkdsk gives me a whole bunch of error messages:

a) 'Corruption was found while examing files in the directory ‘x’ It repeats this for four different files.
b) 'Corruption due to bad sectors was found while examing files in directory ‘y’ (a subdirectory of directory ‘x’) ‘Entries 0 to 4111 were affected.’
c) ‘The bad sectors will only be repaired if the “r” option is specified’. (I, of course, ran chdsk a number of times with the ‘r’ parameter, but to no avail.)
d) ‘Corruption due to bad sectors was found while examing files in directories ‘a-z’. Entries 0 to 4xxx were affected.’ (It repeats this same message for some 27 different directories). And then gives me the command prompt – without having fixed anything.

  1. I was able to change the drive letter of the microsd card in windows disk management (hoping that it would resolve the problem), but it didn’t.

Any help would greatly be apppreciated, as I have* really* important files on this card.

If I need to use a file recovery software, is there one you would recommend ?

Thanks very much in advance.

Hi @coco54,

Thanks for reporting the issue. Have you opened a Support Case? If not please click here and open a new support case to assist in the best possible way.