Continu blue led wireless 128 gb usb

I pressed the on/off for about 15 seconds and now I have a continuous bleu led light and I am not able to turn it off or make a connection anymore. I can’t detect the Wi-Fi. I bought the stick two days ago and it worked fine. What to do?

if you connect it to a computer is it recognized? If so you can try the manual FW update process and see if that will help. if not let the battery run out and then see if it will charge or turn on. If not it would likely need to be replaced. 

I will try that at home. Thanks

After a few hours the blue led was off. After loading the stick all works fine again. So I don’t know what happened but the problem is solved.

I have the same problem. It is now 30 minutes since the blue led on, the moment i write this comment, and nothing i can do with the stick. Tried to plug in to laptop, but also not detected. I will wait for few more hours to see if it will recover by itself.

btw can someone in sandisk explain, what is this blue led means? And why it behaves like this?