Connecting to PC

I have connected my Sansa Clip to my PC using the USB2 ports in the front of the CPU.  The Clip screen reads ‘Connected’, but the Clip does not show up as a drive on the ‘My Computer’ screen.  I have XP SP2 installed.

The clip is set to the ‘Music’ menu and is fully charged.


Try switching the USB mode on the player to MSC. It should then show up in Windows Explorer under Devices With Removable Storage alongside your CD and/or DVD drives.

If that doesn’t work, also try other USB ports, and a different USB cable if you can.

Or you could try this, to force the Clip into MSC mode.

  1. Turn device OFF.

  2. Slide the  Hold  switch down to  Lock  (orange color showing).

  3. Press and hold the center button while connecting the device to the PC.


This worked!  Thanks much

Using the Settings menu on the Clip to force the Clip into MSC mode worked.  Thanks.