Computer not recognizing new Clip+

I have read through te archives, and nothing seems to work.

Running Vista 64, WM11.

I’ve tried setting USB mode to both MTP and MSC. Firmware is 01.01.05 (Can’t upgrade firmware until I can connect the Clip. I tried to connect it to a Windows 7 machine, but it didn’t recognize the Clip either.)

I’ve tried to manually add an MTP device in Device Manager, but that didn’t work. And I tried Microsoft’s MTP Porting Kit, and that didn’t work either.

Is there anything else I can do to get the Clip+ to show up?

Thanks.

Looks like I have a solution, and since I haven’t seen it mentioned elsewhere, I’ll add it for posterity.

The Clip+ comes with a USB cable. It’s a typical UBS-to-mini, so I threw it in my box of redundant cables and used the USB-to-mini that I use for everything else. Well, while the included USB uses standard connections, it’s not a standard cable, and when I used the included cable, everything loaded fine.

A standard cable will charge the Clip+, but in my case, only the included cable can make the connection.

Some USB cables are power only, or it could  be that your other cable is damaged so data transfer doesn’t work properly.

I’m using an off-the-shelf usb<->mini cable and it works fine.