Code 1 error - MTP not working - e250

I keep getting a Code 1 for my e250 on my device manager. I have XP Pro w/ Media Player 11. It works fine in MSC mode, but I can’t get it to recognize in MTP so my playlists won’t transfer over. What could be the problem?

Message Edited by TroyAndEddie on 07-31-2007 12:59 PM

Has it worked previously in MTP mode or was this your first time trying to connect it? Also, when it’s connected in MTP mode, does it show up in My Computer or just Device Manager?

The first thing I’d try doing is uninstalling the player in Device Manager and then ‘reinstall’ after restarting your computer. It’s possible the player just didn’t install properly in MTP mode (which causes your computer to see it as a completely different device than when it’s in MSC mode).

That’s my two cents - someone else may have another suggestion.

It was my first time hooking it up (after the full charge). I just brought it to work, and it hooks up fine (I have Media Player 10 here). Might it be my USB drivers?

I tried the uninstall/reinstall, and it doesn’t show up in My Computer in MTP mode, just MSC.

Message Edited by TroyAndEddie on 07-31-2007 01:20 PM

Message Edited by TroyAndEddie on 07-31-2007 01:53 PM

It could be the USB port, since MTP does require more power than MSC - but unless your home computer is a laptop, I’m not sure that’s the cause. Have you tried plugging the player into your rear USB ports (if your PC is a desktop, that is!)? If not, it’s worth trying.

The next thing I would try is downloading and installing the following update:

http://www.microsoft.com/downloads/details.aspx?FamilyId=73C2650F-BE61-4BD6-8408-1FD6E7827CD8&displaylang=en

It’s a update that’s related to DRMs and MTP devices and will sometimes fix issues of the player not being recognized.

No dice. I tried the back USB ports with the same result. I’ve got a regular desktop, and I’m not sure what to do about the USB port. Should I uninstall and reinstall the drivers? I’m gonna rollback my media player to 10 and see what that does. I’m conflustered.

Well, it definintely must be the PC. I hooked it up to both my laptops and it connected just fine. I just turned on my network, created playlists on the laptop, and copied my music via the shared folders. Not ideal, but it works. I’m gonna try to figure out what’s bonkers on the desktop.

Media Transfer Protocol Porting Kit

Im not sure if this will fix the problem but give it a try…