Cloudspeed Gen. II SSD firmware update?

@lsi wrote:

Since it seems that noone has ever answered this question here or in the Enterprise forums, the half baked Sandisk Guard Tool utility doesn’t work with its default firmware update settings under Windows.


The method to get it to process without errors is to use the non-default firmware update mode (second option in the list I think) which allows you to specify the offset / block size.  Via trial and error with common block sizes, I found that a block size of 256 was accepted and updated my Ultra Gen II drive from ZR07 to ZR08.


Even with the latest update on my drive, performance is still very marginal on consumer-type controller platforms (Intel SATA3 in AHCI mode during my tests) and light-load / QD1 performance is conspicuously low.  This leads to very bad scores on consumer-type benchmarks such as PCMark tests, so I wouldn’t recommend people snap these up to use for non-server environments.  Their firmware is likely specifically optimized around LSI-based hardware RAID controllers vs consumer controllers, so I wouldn’t expect improvement this far into the firmware’s development either.


There seem to be plenty of bricked versions of these drives floating around eBay with customized non-generic firmware, so updated firmware appears to be crucial for long term reliability–and that generally isn’t possible if the drive is not a generic one that can be updated with this unfriendly / DIY-class-support enterprise utility.

ve used SanDisk guard tools for windows. I have tried on Pike 2108 and adaptec 8405 but its not possible to find the disk when its in raid. I have tried with USB 3 sata hdd dock and usb 2.0 sata hdd dock. i have tried to use it on sata controllers on many different pc’c and server’s, but its not possible to update. It says updated but its still the old firmware, if i use it on sata controllers it say:

Updating failed

Not being able to detect & apply firmware to drives inside a RAID array is normal and expected behaviour, unless you are dealing with customized firmware updaters produced by manufacturers for their own certified (modified) firmware versions such as Dell, HP etc.

Not being able to do firmware updates on drives via USB adapters is also normal and expected behaviour across all drive manufacturers, older updates used to require IDE mode and most modern updaters needs SATA drives direct connected to a controller in AHCI mode (and often only with msahci drivers vs Intel RST or AMD SATA drivers etc).

Sandisk’s utility, despite newer updates, is still one of the worst and least unintuitive utilities I have ever used–which requires a non-default flash mode and custom block size (256) to be used to successfully update firmware once all those other conditions are met.

I have repeatedly updated multiple Cloudspeed Eco and Ultra drives successfully using this process, with firmwares ZR08 through ZR11–but don’t expect any dramatic improvements.  Sandisk doesn’t seem to have the motivation (or skills, since these bug threads have been in their forums and across the net for years now) to enable their “enterprise class” SSD products to work on Dell enterprise PERC controllers without being flagged yellow / failed in hot swap bays.

It seems that despite the apparent value and competitive performance of these drives, Sandisk doesn’t really take their implementation into real world environments very seriously–even when we document specific bugs and have to document the processes to use their own management utilities effectively in their own forums.

Until Sandisk gets serious about fixing their firmware management tools and glaring firmware bugs (re: Dell PERC compatibility), people should be looking to more competent enterprise drive manufacturers like Intel and Micron.  Samsung doesn’t focus much on the “generic” enterprise SSD market either, and has historically cut some ridiculous corners in firmware design (like not properly monitoring & testing their power protection circuits) so I wouldn’t waste your time there either.  These drives really only deserve to be used in very basic & generic “light enterprise” / SMB implementations where the drives are used on simple SATA controllers.

The Cloudspeed drives also have quite high write latency under stress, which can easily be reproduced in a matter of minutes by running an AS-SSD 10GB test vs its 1GB default.  Write latency skyrockets beyond the mentioned Intel / Micron products (comparing to pretty much anything ~5 yrs or newer gen in my tests), even on ZR11, and there is no significant difference between the Ultra G2 & Eco G2 despite the Ultra G2 having 3x the write endurance rating.  So the Ultra G2 seems to be simply designed to withstand write activity vs being legitimately optimized for it.  If that is truly the case, simply overprovisioning a large Eco G2 drive would probably be more effective than paying for an “Ultra” class drive.

Надо переименовать расширение файла прошивки в .bin

для примера так:


Затем данный фаил позволяет прошить данные SSD из под программы

SanDisk SSD Dashboard штатные образом.

Прошивки лежат в папке  архива cloudspeed2-eco-ultra-fw-zr11

для дисков


а так же подходит для SDLF1xxx-xxxx-1J2