Clips won't charge and no longer show up in Windows Explorer

This one has me perplexed. I downloaded a podcast tonight and transferred it to my 2gb clip with no problem, and it played fine.


I later tried to check the battery level of my 4gb clip, and the clip icon didn’t show up in Windows Explorer as it always does. Also, the clip’s screen shows “Connected” but is not charging, even though it’s connected properly and has about 50 percent battery life. I went through the same routine with my 2gb with the same result - “Connected” but not charging, and no clip visible in Windows Explorer (or Rhapsody or WMP11, where they also always are visible).


I’ve tried switching cables and switching USB ports with no luck.


I’m running Windows Vista, and the little sound that is emitted when the clip is first connected was different from the normal sound. Something is wrong, but I’m not sure what it is.


Both clips still are playing fine with headphones, but as of now I’m unable to transfer anything to either of them.


Until now my clips have been problem-free. Any suggestions?



I doubt that this is your issue, but:  my machine (computer) sometimes will do this and it’s caused when the computer, for some odd reason, assigns the same drive letter to more than 1 device.  The solution is to go into the Windows Device Manager and to manually assign the Clip to a different drive letter that has not been already assigned–any old letter will do.

I found the answer in another thread, and it worked. Holding the center button down while connecting to the USB cable did the trick. Thanks.

That connected you in MSC mode.  To do that easily/automatically, change Settings/USB to MSC (if your firmware version doesn’t have that, upgrade to the newest; the link is in one of the top sticky threads in the forum).