Clips battery went low and now wont connect

Hi all,

I have been using my clip happily for more than a year. So far I have always used it enough every week to keep its charge pretty high. Last week I let it go too low and suddenly it would not connect properly, ‘USB device not recognized…’. Won’t power on because of the low charge and none of the tricks of locking and holding the center button worked. Tried different USB ports, laptops, desktops, new cables, none worked.

Finally I stumbled upon a post that suggested that I plug just the tip of the USB cable in as the longest pins are power pins. Wonder of wonders this did charge the clip up. So after a full charge, I tried to connect again. No such luck, ‘USB device not recognized…’ again.

So I formatted, reset, forced MSC, MTP stood on one leg, but nothing works. USB device wont be recognized. I am really sad to see that a low battery charge makes the clip a brick (well a pebble).

Any help is appreciated. And the trick of putting just the tip of the USB cable is a beauty, it worked for charging without connecting.


Thanks for the link. I cannot get past the ‘USB Device not recognized’ in any mode. This is a big downer. How can a perfectly working device go off the clif because the battery ran out once?

Did you try charging it with a wall charger?