Clip+ won't open using Windows 7

Hi fellow Sansa users,

Here is the deal, I bought my Clip+ way back in Sept 2010 and I am very familiar with all the tricks that have to be done in order for my brother’s computer (Win XP with Windows Media Player 11) to detect my Clip+

I’ve done the “necessary steps” atleast 4-5 times because he had to reformat his PC from time to time.

Now that I have my own laptop, I cannot seem to make it work. I have read almost every thread about this problem but I have never found a real solution. So I am writing my own case with full details.

What I have:

Windows 7 Home Basic

Sansa Clip+ 4GB Blue

Windows Media Player 12

MTP Porting KIt Installed

Intel i5 2nd Gen

Brand new laptop so don’t tell me that it could be a USB port problem, I have tried the two 2.0 ports and one 3.0 port

Standard USB cable

What I have already done:

Switching it on while holding the middle button

Changing it to MSC mode

Changing it to MTP mode

Changing it to Auto Detect mode

And yes, my Clip+ is chargiing when I connect to any of the USB ports.

I have done these already so don’t tell me to:

Run device manager and click update driver or something, the yellow question mark icon wont even show up

Update firmware, (firmware updater/my laptop wont even recognize my mp3 player)

Update Windows Media Player (I have already have the latest WMP12)

Install MTP Porting Kit (already installed)

Now, can anyone of you still suggest something worth trying? Please don’t tell me to just transfer MP3s from my brother’s PC because it will just defeat the purpose of me buying my own.

Please only reply if you have something good to say, Thanks in advance!

You don’t have to do anything to use a Clip+ with Windows 7. Assuming the device and computer are functioning correctly, both MTP and MSC mode will both just work. If they don’t, something is wrong with either Windows, or the Sansa. When you plug in the player, does Windows detect any new USB device at all?

My laptop is just two weeks old so I dont think it’s a hardware problem or even a software problem (corrupted os issues, viruses, etc).

All of my USB ports are working fine, I tried the three ports with my usb modem, usb mouse, game pad, 3 flash drives so I dont think it’s also a USB port problem. I have also tried 3 different USB cables,

There is nothing wrong with the Sansa itself because it’s working fine on my brother’s computer.

When I plug in my player, it only charges. No notifications whatsoever. Not even in the Device Manager screen.

There should be no need for the MTP porting kit in Windows Vista or Windows Seven…the drivers are native to the OS. The porting kit was only necessary for older systems, like XP.

Try setting the player to MSC mode, then try the following. Connect the notebook to the wall charger before plugging in the Clip+. Disconnecting all other usb peripherals before connecting the Clip+. What happens after you connect the Clip+? Have you tried opening Windows Explorer(right click on start, click on explore) after you connected the player to see if the pc has it listed there? It might be that the pc is recognizing the Clip+, but not taking any action, and not opening a pop up window.

I am currenty at work, will reply to this later.

Marvin the Martian, I already know that. I just tried everything that I can.

I really appreciate your input but what I need is a SOLUTION and not comments about what I already did in the past.

I appreciate if you will only reply with something useful.

JK8, I still have to try your suggestion.

As for yor quetion, it is not opening up in the Windows Explorer, it is still also not listed.

Does anyone here has the same problem with me?

I am having the same trouble to the T. and well I am having no luck either. I am about to chuck this **bleep** thing and go buy a real mp3 player. or just get another ipod touch or something better than this pile of crap. sorry but so true

The software MTP Porting Kit is not needed. If you have firewall software installed on the PC, check it’s setting to ensure it’s not blocking access to USB drives. Check to see if there is some kind of third party USB Manager software installed, if so try disabling it or uninstalling it. My Sansa Clip+ was recognized by my Toshiba laptop with Windows 7 Home Premium right out of the box, no need for extra software or drivers.  

Are you guys using the orginal USB cable that came with the Sana Clip or a differnet USB cable? Perhaps its the USB cable that is causing the issue, try the original USB cable that came with the Clip.

Using the USB for the Clip worked.  I was using my blackberry USB because it is longer and worked fine with my Clip on my old computer but will not for this one.  

Look 8814princess, nobody questions that both you and the op are having problems, but millions of others have no problem with getting clip devices to work, so labelling the device as crap is hardly appropriate. By all means go buy something else, good luck.

As far as the op is concerned, there is something amiss with his laptop, and that something is difficult to pinpoint via a news group.

I’m no expert with W7, but with my Dell Inspiron the USB ports did not function correctly until I installed the driver from Dell.  I still get some goofy “installing software” notice when I plug any USB device into it.  In any case W7 worked with my clip at least in MSC mode.  I was able to copy and paste files and play some mp3s from it. 

Mine won’t load either, and I have used all of the suggestions.

Would any of you have the Samsung software KIES or HTC sync or a similar program installed on the pc where the player is not detected? If so, disable to processes of the software in task manager and try the clip again.

I’ve attempted all the suggestions and my Windows 7 will not recognize my Sansa Clip Player.  I don’t know what else to try.  My computer says the device drivers are updated and it recognizes the device in device manager on my computer.  It does have a yellow exclamation point though.  This is so discouraging as this was not a cheap player!  I hate to just pitch it.

Can you uninstall the driver (right click and choose uninstall) under Device Manager and then re-connect, forcing a driver reinstall?