Clip+ won't charge; not recognized by computer

I bought a Clip+ in January and was able to charge it and load it with songs on my desktop.

I am now on the road with my laptop and the Clip+ stopped playing yesterday after about 4 hours.

At first, when I plugged it into my laptop, it would not charge and my laptop would not recognize it. I kept unplugging it and re-plugging it and eventually, it worked.

But, today, after a full charge, it again stopped playing after about 4 hours and, again, I cannot get it to charge or be recognized by my laptop.

Any suggestions?

Thanks,

John 

Have you tried a system reset?  Hold the on switch down for 15-30 seconds.

Thanks, much. What switch should I hold down?

John

Hi ~

Ah, I re-read your message, and I should hold down the “on-off” button to re-set the system.

Fortunately, I tried the Clip+ again and it immediately was recognized by my system and is recharging just fine.

But, should it go ‘incognito’ again on me, I will give this a try.

Thanks so much !

john 

I have the same problem from the beginning: Clip+ (4 Gb) won’t charge and not recognized by computer. I have tried MSC USB mode, system reset, another cable, another OS (Linux and Windows).

Any ideas?