Clip+ WEIRD: Corrupted file not removable, no full reset possible? Read-only?

Hi all,

I’ve managed to create a VERY WEIRD problem on my dear Clip+:

One of the many mp3-files I’ve on it seems to be corrupted, at least the player will freeze every time I try to play it or one that is after it in the currently shown playlist.

Pressing the start button for 20 secs restarts the player and it works fine, as long as I don’t come close to the evil file.


I can connect the player via USB to a PC, (even if it seems to take much longer to recognize), but the WEIRD thing ist: Whatever I do in Explorer (like deleting the evil file, or deleting all mp3, or deleting all visible files, or adding an mp3, or placing the bin-file for a manual firmware update (I already have 1.02.16), or even following the installation of Rockbox bootloader an software, which finalizes without an error message), so whatever I do at the PC seems to work fine, and when I disconnect the player, it will do its normal “database updating” and BE TOTALLY UNCHANGED LIKE IT WAS BEFORE - all (and only) the mp3s from before in place, at the same bookmark, the same resume point, and the evil file will still be there, too.

I tried to no avail:

  1. Deleting the evil mp3-file in the player menu - can’t go there, because opening the file causes a freeze

  2. Resetting to factory settings - no effect. I go there in the menu, confirm “yes”, he asks me new language and region and goes back to the m menu point “reset to factory settings” without delay, and without doing anything.

  3. Win 7 command prompt:

 chkdisk tells me he found errors on the disk, and when I give him /F (fix Errors) does nothing, but without complaining.

 He also wants to convert lost chains to files, which i made him do - to no avail

 format /Q (quick) says: Invalid media or  Track 0 bad - disk unusable.

…and still, after bing disconnected, the stupid thing is as it was before and happily playing most of the files.

It just seems somehow read-only, but in a way that the PC doesn’t notice.

I’ve nearly given up, but I would love a possilbe explanation.

Any ideas?

Run Chkdsk again, but this time tell it not to save lost chains as files. It’s essentially saving the problem that’s causing the player grief in the first place only in a separate file.

Then format again, but regular format, don’t use the Quick Format option.

Thank you a lot for answering!

Okay,  I tried.

chkdsk /F without converting chains:

“A disk error occured during writing of the file allocation table”

format f: takes a lot of time “verifying 3751MB”, counting the percentages up to 100%,

and then gives me the same as quick format: “Invalid media or  Track 0 bad - disk unusable”

After disconnecting, the device is totally unchanged.

Any other brute-force ways to overwrite EVERYTHING? Or Linux, anyone? I could run a live-distribution, but I don’t know the tools there.

(Ah, btw: If i delete any of the good mp3s, using the menu of the player, it will seem to regularly disappear but be there again when I turn it off and on. It’s simply not possible to change whatever’s written on the disk.)

Can you reformat under the Clip’s System settings?

Thx for the idea, but same problem: He makes me confirm it, then “formats” for some time, and afterwards the drive seems empty (shows no mp3 files).

But when I turn him off (normally, without holding the button for longer) an back on, everything ist back as before.

Btw I found two additional directory trees called “##MUSIC#” and “##PORT#” in the root directory, but I can’t delete them either and I don’t know if they have anything to do with the problem.

(They are there since the beginning of the problem, I just  compared only today with another Clip+ of a friend to understand they’re not normal.)

At least I’ve found out that I can still play new music from a memory card, only I have to re-insert it to rebuild the database after every on-off because afterwards he will show them as empty otherwise.