clip+ stuck on refreshing youre media after reformat


I searched for an identical situation, but couldn’t find one to this. I downloaded some music and everything went well, listened to it, listened to some other music, turned the clip off and the next day I get the frozen flower freeze on the screen. none of the usual remedies are working so I go to update the firmware, but the most updated version is already there so no update available.

I then decide to reformat and I can get past the flower screen, but the screen just sticks on the refreshing your media screen.

any idea? is my trusty player just hitting the end of its life cycle? is there a way to reinstall the firmware I currently have installed?

any help is appreciated.

forgot to add, I do not use an SD card and never have

figured it out and i’m posting in here for posterity’s sake–in case anyone runs into this in the future or searches for it.

I manually installed an older version of the firmware and was able to get the clip+ to work again. have to reload my media, but it’s working again. and thankfully because i really dig this mp3 player and it’s a bit expensive to buy a new one.

Glad whatever you did worked, and thanks for posting. But manually re-installing either an older f/w version or the latest should not require you to reload all your content onto the player. Only formatting erases what is stored in the memory. Perhaps that’s what you did?

this is my exact problem with player stuck on ‘refreshing media’. but dont understand how to manually update when none of the buttons on player work, even when plugged into computer to attempt to find different settings.  Please help. 

I reformatted after realizing I had the most up-to-date firmware. after reformatting, it was still not working so I then manually installed the old f/w. so i did both, but i think the fix was manually installing the f/w

i had to turn my player completely off and ensure that it had been plugged into a charger long enough to hold a charge of over 50%.

with the player turned off and charged, I plugged it into my comp’s usb and manually installed the f/w. do a search on the forum to see how to manually install firmware. sorry, i don’t remember the link where i found how to do it.

Hi I have this issue with the Refreshing your media but where do you get the older firmware to resolve this

It’s not publicly available, but if you’re creative, you can still download these versions:
Simply copy the download link and change the 1.02.18 in the link to whichever firmware you would like to download