clip+ stuck in "writing"

Just bought a refurbished 4g clip+ from newell.  Installed Sansa updater.  Think I have updated firmware(or it already was) to V01.02.16A.   shows memory of 3750 MB and free memory of 2278.  Shows no music available.

When I plug it into USB it stays in the “writing” mode.  Tried resets.  Will clear and radio works and recorder works.  When I plug back into USB stays in “writing.”   Did this on desktop and laptop.  It says I have 0 songs.  I thought I was syncing with Windows media player and…nothing.  

First issue is to get out of “writing” mode.  Second, should I only have 2278 free memory with no songs on the device?  Third, how big a mini-SD card will it support?

I have tried different USB cables and computers.  My desktop recognized a “MTP” device and asked for a reboot.  I did but no change in “writing.”  WMA does not seem to recognize it now.  

All help appreciated.

Try a reset. Hold the power switch in the powerdown position for about 15 seconds. It should do a reset.

I have done many resets with no success.  Keep the ideas coming.

Format it (from Settings > System Settings > Format) and try re-loading again.

that worked. no wonder you are called a 'guru."  most impressed.  thanks