Clip Sport FF/RW really slow

I’ve been a fan of the Sandisk products for a long time.
My 5yr old trusty Clip Zip sustained a cracked navigation button at front right, after I dropped it one last time!


What a great little player it has been - daily use for years, round the world multiple times, dropped in the toilet, mouthed by my dog,  abused by the TSA, (who hasn’t been) xrayed, - and still works.

So I researched the current offerings and purchased a 4GB Clip Sport running firmware 1.29
I duly noted all the deficiencies connected with the new design functionality / processor etc, but decided it would suit my simple needs.
No music, playlists, or Audio Books, just podcasts I download from a laptop.
I have to say the sound, speed of most operations - Pause - On/Off etc is way better than my Zip…


So, to my question :smiley:
I like to scroll (fast fwd / rewind etc) within a podcast to get to the content I want to review.
The speed of this operation is very slow like treacle…
The Clip Zip would pick up speed the longer you held the fwd/rwd button.
Is there any way to speed this operation up?

TIA
euroukus

@euroukus wrote:

I’ve been a fan of the Sandisk products for a long time.
My 5yr old trusty Clip Zip sustained a cracked navigation button at front right, after I dropped it one last time!


What a great little player it has been - daily use for years, round the world multiple times, dropped in the toilet, mouthed by my dog,  abused by the TSA, (who hasn’t been) xrayed, - and still works.
 

You sound like a great ad for SanDisk!   :slight_smile:

According to another manufacturer which is using the same SoC that Sandisk does in the Sport it’s a hardware limitation. Apparently the chip is only capable of a maximum search speed of 8x.

According to another manufacturer which is using the same SoC that Sandisk does in the Sport it’s a hardware limitation. Apparently the chip is only capable of a maximum search speed of 8x.

------------------------------------------------------------------------------------------------------------------------------------

Yes - I suspected as so.

Thanks for the replies !

e

Clip Sport - died this week. After only 21 months.

Disappointed.

Problem:

Won’t charge - Battery must be fried.

While on charge it just displays ‘Transferring’ … rather than the ‘Charging’ message.

Was still able to retreive my content and save it to laptop.

I am going to attempt to replace the battery…I’ve found directions online and a source for a new battery.

Nothing to lose.

So - I purchased an 8GB Clip Jam…$30.

So far it suits my useage. (No music playlists etc - just podcast and radio)

Apart from screen size, the only difference I’ve seen so far is it does not have a EQ selector, but rather just a preset default EQ which sounds fine for both spoken word and radio.

Thx Euroukus

@euroukus wrote:

 

Problem:

_ Won’t charge - Battery must be fried. _

_ While on charge it just displays ‘Transferring’ … rather than the ‘Charging’ message. _

Was still able to retreive my content and save it to laptop.

 

Are you using the cable that came with it or an after-market one?

Cable that came with…

After leaving it hooked up to charge for a couple hours, unhook it and try to start unit  - nothing.

I have used other cables with it occasionally…but mostly the OEM.

Thx