Clip+ resets when connected to Archos 605


This is my first post here, so thanks for having me, and hope you’re a friendly lot :slight_smile:

I bought a clip+ yesterday for my son.  I tried to connect it to my Archos 605 using MSC type USB - it  just seems to reset a few times then freezes.  Connecting to a ‘normal’ computer (running Linux) works fine.  Has anyone else encountered this and have any ideas why this might be?  Otherwise it looks like a cool little gadget!



I can’t say for sure, but my guess is that the Archos isn’t designed to act as a host for other USB devices.

Thanks for the suggestion, but it works with other mp3 players/usb sticks etc.

Interesting. Have you tried connecting in MTP mode? (I wouldn’t expect that to work, but hey, I’ve already been wrong once…)

'Fraid so - I’ve tried in Autodetect, MTP and MSC.  I wasn’t expecting MTP to work either…  Just checked on the Archos forum and someone else’s clip (not plus) didn’t work either.  I just wonder if the Clip doesn’t use a fully standards compliant version of MSC - or the Archos doesn’t, although it’s the first thing I’ve attached which doesn’t work.

Bummer. Not being familiar with the Archos, the only other suggestion I can offer is to try resetting the Clip. Press and hold the power switch for 15-20 seconds. Then turn it on normally with a quick press and try connecting to the Archos again.

My thought would be that when using a flash drive or whatever there is a connection in 1 direction not a Read/write. I know other types of players can read and not write or vise versa but not both at the same time. Maybe thats the difference.