Clip Power Problem -- Also Not Recognized By Computer

I own a Clip 2gb and love it – however I am having a problem that I hope is an easy fix.

My Clip is completely dead with a blank screen.  I thought it was just a drained battery, however when I tried plugging it in to my USB port (2.0) and it will neither charge, nor be recognized by Windows. 

  • I have tried reseting the Clip via the FAQ instructions – no luck.
  • I tried charging it using three different computers – no luck.
  • I have the latest version of Windows Media Player.
  • I have connected it to the USB port with the Clip Hold button slide down and center button depressed – no luck.
  • I installed the firmware update previously (within the week).
  • I tried charging it (leaving it connected overnight) despite the blank screen – no luck.

Am I missing something? Or should I call Tech Support?

Sounds like you’ve done just about everything–you might also try charging from AC if you can.  But it sounds like it’s time for Tech Support …

Returning the Clip via RMA was an absolute pain.  So I returned it to the retail outfit I bought it at and THEY decided to RMA it for me – and gave me a new one.  Pretty cool huh?  But the story doesn’t end there…

My girlfriend bought a Clip also, so this time I bought insurance for an extra $10 just to be safe.  Good thing I did, because I have had to return the Clip twice since then – with the same problem.

The Sansa Clip has serious power issues – as evidenced in this forum and in Google’s search results (Keywords: “sansa clip” no power).