Clip+ not recognised by Windows 7 any more but charges it?

Hi. Firstly I have never had a problem before but recently when connected to Windows 7 the Clip+ starts charging but Windows does not recognise it. It is shown in Devices. I have tried all the methods of resetting suggested (hold down power button 20 seconds - 2mins some time), holding Power and Menu button and receive message “do you want to remove old firmware press centre button for OK” and I have done that too, still nothing works. As Windows doesn’t recognise it I can’t remove, reinstall or install new firmware. Tried different USB ports and leads. When starting up with Micro SD Card inserted Clip+ just hangs so I can’t use the Clip+ at all now. Help please, thanks. Chris

The connection issue could be on the Windows side.  You might try uninstalling the Clip under Windows’ device manager, and then connect up again–this forces Windows to create the connection anew, which sometimes can fix a faulty connection. 

Hi.Thanks for your suggestion, however I forgot to mention I had already done that too and Windows still doesn’t recognise it. I While in Device Manager I also “scanned for hardware changes” and the scan came up with nothing. I am sitting here with the Clip+ attached to my laptop and it is charging, and I can use the buttons to go round the Menu and watch it charging but Windows 7 still does not recognise it exists. Any further ideas? Thanks.

I’m totally guessing now.

I once had the issue with a USB peripheral–a music player–that it wouldn’t connect up, and it tuned out that Windows had assigned the device a drive letter already in use by another device–apparently, this error happens.  You can check this under Disk Management and, if necessary, assign a new drive letter by right-clicking on the drive. 

Another possibility:  can you try a different USB port?  And how about a different USB cable–oddly (to me, at least), they actually can go bad.

Lastly, if you can afford to lose the content, you could try re-formatting the Clip, under its System settings–that sometimes can fix odd matters (I can’t see it fixing a connectivity issue, but I’m just guessing at this point). 

Hi. Already tried all the USB ports and several leads (mentioned in original post), formatted it too. Checked Disk Management all OK and while in Disk Management ran the scan for devices - no changes. Any further ideas? Thanks for your help so far. Chris

If you can charge the unit and turn it on, go to Settings/System Settings/USB Mode and put it in MSC. That’s the most likely way to get it recognized by Windows. 

You probably know this but the USB connection uses two different sets of pins: one for charging, one for data. 

It’s possible the data pins inside your USB port are damaged, and if that’s true, repairs aren’t worth it. 

Since you’re still getting a charge, you could  use a card reader to put music on a microSD card and use the unit that way. Not ideal but it would do the job.

Never seen that “replace the firmware” message–that is REALLY odd.  

Thanks for advice, however I have tried MTP, MSC and Auto and none of them works. Tried transferring music to newly formatted MicroSD HC card and although Windows says it’s OK. The Clip+ opens to the Sandisk Logo and freezes with the card installed. Without the card it opens normally. Once you push the card in open starting the Clip+ it says “refreshing your media” and believe it not it now shows the music I installed from the laptop, however the internal is of course still empty. So I can at least listen to some music on the card but it still doesn’t explain why the Clip+ is not recognised by Windows and as a consequence I cannot load anything on to it’s internal memory or change/upgrade the firmware. Frustrating.

I hate to ask, but:  are you still within the warranty?  (1 year U.S./2 years EU.)

You also might try out SanDisk tech. support:

Well, the internal memory in the unit could be messed up.

Since you don’t have anything on there it wouldn’t hurt to take out the microSD card, go to Settings/System Settings and Format the internal memory. That won’t affect the firmware but could clear up problems. Do it a couple of times and see if it helps.  

Hi. No, unfortunately I am out of warranty but I will check out the link you have posted. Thanks

Hi. That seems to be the only explanation which presumably gives rise to Windows 7 not being able to see it (although it always had previously). I did format it earlier with no joy but there’s no harm in doing it again a few times just to see if that clears the problem. I will let you know how I get on. Thanks.

Hi. FYI,  I have found that if you hold the Power, Centre and Bottom Menu buttons down at the same time when turning it on, you are given the message “clear firmware? Please push centre button to confirm”. Which I have done a couple of times now but it makes no difference to resolving my problem.

Hi. I did format it earlier but having tried your suggestion and formatted it a further 6 times it is still not recognised by Windows 7.

Hi. Of further interest believe it or not. I have just formatted the MicroSDHC card using Windows 7 and dropped a dozen MP3’s on it. I have confirmed this with Windows 7 and they play OK, however, When inserted in to the Clip+ it reports that the MicroSDHC card is empty! So not only has the internal memory failed but now the external memory too. Thanks for all your advice, but this is starting to look like scrapping it and looking elsewhere for an MP3 player. Confirmation anyone? Regards.

Maybe you just got a lemon. At this point I’d suggest a replacement or a phonecall with tech support.  

Some other thoughts: 

Are your new mp3s properly tagged? Have you gone down the Music options to see if they are visible in Folders?  If there are no tags (or ID3v2.1 tags or, I think, ID3v2.4 tags) then Artist, Album, etc. won’t be listed.

You’re right about the power-center-menu offering the option to clear the firmware. Had no idea. 

I have to wonder if doing that has contributed to your problems, since the firmware is the operating system for the unit, but you’ve said you were still getting the menus, settings, etc., so there must have been backup firmware on there. 

One other thing you might try is a non-Windows 7 computer, preferably XP, which doesn’t have a lot of the security obstacles of Vista and WIn7. Put it in MSC, see if it connects, and if miraculously it does, drag over a new firmware, unzipped from this thread using the Manual instructions:

Hi. Tried different USB ports 1.1 & 2.0 on Desktop with Windows XP and although it charges it s still not recognised. Followed the link you kindly put on your previous post and after quite a bit of to and fro with Sandisk Support they have no answer whatsoever and suggest simply putting it in the bin. So, thanks very much for all your suggestions and I am now looking for a new MP3 player. One of the reasons for the Sandisk Clip+  is its ease of use when dragging and dropping MP3’s etc because I have never been a devotee of anything from Apple. I will now start looking for a new MP3 player and unfortunately I will not be buying anything from Sandisk just in case the fault (whatever it was) is duplicated, Thanks again. Kind regards. Chris

Well, I’ve used three versions of Sansa players (E200, Fuze and Clip+) and never had any problems with MSC drag-and-drop that weren’t fixable with either a reset or (after one disastrous experiment switching to MTP and having Windows Media Player go wild) a format.

 I’m on Windows 7 64-bit, and both the Fuze and Clip+ have been just fine with it.  I did at one point have to replace a USB cord that was failing, but I think that was back in the XP days. 

The best explanation for your problem is a mechanical failure in the micro-USB jack on the unit, in a unit you’ve had more than a year, presumably with some use.

Since you can get a refurbished 4GB Clip+ from Amazon for all of $20, with Amazon’s buyer protections, it might be worth a try.

Otherwise, sure, look around for a different brand that does the MSC connection, but it could get a lot more expensive. 

Thanks for the advice, i may try that however I am in the UK and on Amazon here a refurbished 4GB is over £20. Thanks again.

I joined this forum simply to post that for me, it was simply the cable.

No reason I understand does one mini USB work, and another doesn’t.  Both charged.  Only one connected to be recognized

Hi. Thanks for the thought but tried different cables too. It used to work fine as there were no other suggestions that i could try I took Sandisk Support advice and binned it :frowning:   Now keeping my music on my Samsung Note 3 32GB SD card with no problems whatsoever plus Bluetooth through my Soundbar when home and in my car. Regards. Sandisks loss.