Clip hangs at boot screen "flower petals", cannot connect to computer, will not play

Hi, I’ve got the 1st generation 2g clip. Updated to the newest firmware a month or so ago, the 1.x version, and after loading a large folder (700mb) into the music directory a few days ago, the clip has hung during operation, then stopped refreshing the database, then hung on boot every now and then, until it finally will not boot. So it wasn’t sudden–but it’s like it slowly got scrambled, then kaput.

Did all the usual stuff when I could still connect it up–I formatted, checked for bad sectors, reinstalled the firmware, etc–nothing helped and now it’s just dead.

Does the same thing after any hard reset–boots to “sandisk” then the petal things, upon which it hangs up. I’ve tried it all, holding the button in while connecting to force MSC mode, plugging it in both frozen and powered off. Nada.

Curious if anyone else has had this happen? My warranty is expired–but it rubs the wrong way since the player is very lightly used by an adult, and I’ve recommended it to dozens of people–I certainly don’t want to be hearing their complaints on the one year life on the unit.

Any ideas? I’m guessing that the firmware just got scrambled–but then–if I reinstalled it and formatted it…what gives??

Thnx,

M.

Here’s another clue: sometimes when you leave it at the “Petals” screen for a few minutes, it will refresh the database which takes a good 1-2 minutes, odd considering it has no music on it after formatting, then I get dumped to the menu, but as soon as I try to use it, it locks up again.

Still can’t connect it to a computer and get a drive icon, tried in both Linux and Windows.

Hmmm. :confused:

It managed to fully boot and connect precariously under *nix–Windows won’t have any part of it. Unfortunately when it mounts up–which is a matter of switching it on and leaving it on the dongle with a prayer for a while–it’s read only. Which means one can’t throw a firmware bin file on it.

Also of note: a whole bunch of odd files, and the drive only looks to have 45mb left even though the music directory has been emptied and formatted. Here’s a screenshot:

 

“Unfortunately when it mounts up–which is a matter of switching it on and leaving it on the dongle with a prayer for a while–it’s read only.”

You can’t change this? Can you see all the files on the player? Make sure none are read only. Next try again to change the drive from read only. I image if it tries to update the database(mtable.sys file) but can’t since the player is read only, it would crash or freeze.

I could probably fooled around and mounted it R/W under *nix, but as the filesystem was corrupted, it mounts read only automatically.

I’ve sort of fixed it as I hooked it to an XP box and managed to mount it as mass storage. It was ornery though, complaining the first few times that I needed to free memory on the OLED screen! Then I formatted it, TWICE, and now it plays with an occasional hang with the blue ring lit.

Hooking it up to Vista it requires being on before you attach the dongle. It wouldn’t even recognize it before I formatted it twice. So it’s on its way to proper clip health. That filesystem must have been hella corrupt. It happened after I used Thunar under Ubuntu to put a 700mb audio book on it. Coincidence or lousy files? Who knows? 

Works pretty well now, though.

I can connect via three OSes, XP, Vista, and even Ubuntu–according to the clip. However, the filesystem is again hosed and nothing is able to format it. Starting it by itself it complains about not enough room for a database. Opening a file manager shows a completely garbled file system–but it cannot be deleted.

I’ve spent $200 of my time trying to fix this $50 unit–as a year of light use should not kill an mp3 player. Of course the warranty went out a couple weeks ago.

Any ideas? Bad cable, hosed unit? It’s not been abused one iota, simply hooked up as mass storage and used an hour or so per day.

 :manmad:

Final update–the Clip is dead. I’ve tried everything to try and format it, down to editing my Windows Registry to get around the “write protect” that the Clip got from being so broken. It boots up for a second or two to the logo, then dies.

Really final update: totally absolutely dead. Won’t power on in any shape or form. :cry: