Clip gone mad

I’ve been using my 4GB Clip revision 2 for a couple of months now.

When I was listening to music on my Clip the other day, the volume suddenly got higher and higher though I didn’t touch anything. I tried the Volume Down button then the others, even the power slider but to no avail. Then I tried the Hold Switch and luckily it worked. But the Lock icon kept showing up, indicating that a button was being pushed despite the fact that I didn’t touch a thing on the Clip then. I slid the slider back to center and tried to power off the device again. Surprisingly this time it worked. Since then, the Clip hasn’t responded to any button I press when powered on anymore. Except when I’ve pushed the Hold Switch to Lock then center position, the Clip responds to a few button presses but shortly after it’s back to Stubbornville again.

I have tried any thing I can think of:

  Let the battery die by letting the Clip play music non-stop

  Plug it to a wall charger

  Plug it to a computer

  Downgrade then upgrade the firmware

  Format then reset it

Please! Help me!

Message Edited by dastan on 05-25-2009 06:00 PM

Anyone? Please! I’m going mad here :((

Contact SanDisk directly for a replacement under their 1-year warranty. There’s nothing you can do as a user, to fix something that’s an internal problem like this.

I was afraid to hear that :cry:

Thanks for your reply