Clip formats automatically when inserted into USB port


I just bought a 4GB Clip and noticed that when I plug it into the USB port on my laptop (running Vista), all music files that were loaded on the player are deleted.  The Clip screen says it’s connected and charging.  When I open up the Clip as a drive in Windows Explorer, it shows that the only file loaded is the DivInfo file.  Any ideas?

Are you certain that they are deleted–do they show up on the player when you disconnect?  On your computer, if the player is set to MSC USB mode, only files transferred to the Clip in MSC mode show up; likewise as to MTP mode (hence the advantage of consistently using one mode or the other).  But all the files are on the Clip. 

Unplug and let the Clip boot (refresh database).  Look for your music files using the Clip’s navigation keys.  As long as they are tagged with ID3v2 tags, your music should be there.  Files transferred in MTP (Windows Media Player, etc), will only show under Explorer in with the Clip in MTP mode.  The reverse is true for directly transferred mp3s in MSC mode.

Hope this helps!

Bob  :wink: 

Thanks for the tip.  I tried checking the player after I disconnected it and the “Refreshing Database” message came up, but very briefly (1-2 seconds).  When I used the nav on the clip, the songs were gone.  It was in on the “Auto” setting in the USB mode.  Could this be a firmware issue?

The Clip shouldn’t drop files on its own, or allow the computer to pull them when connecting, unless Windows Media Player is doing some funky automatic synchronization glitch, which is…nah…let’s give the PC a break.

From the top of this page, download a new copy of the current “20” firmware, and install it manually.  The Updater will see the current FW version (.20) and won’t go further.  On the other hand, if you have a firmware earlier than the 1.01.20, you can install the Sansa Updater and then simply plug in your Clip for a mind meld with the new firmware.

Do this first, and we’ll see how it goes…

Then, transfer a few songs and see what happens!

Bob  :smiley:

Awesome.  It worked after I did the firmware upgrade.  I also kept the USB mode on MTP instead of Auto and that seemed to help with the sync from WMP.  Thanks!

Cool.  Great to hear you’re running again!  You’ll like the features of the .20 firmware too, including the on-the-fly Go List feature.

Bob :smileyvery-happy: