Clip files arent empty but it says they are


I have a Sansa clip 4 gb, settings Version 1.02.16A  Memory 3744  mb  free 316 shwning under info.

All my files were in Audiobooks and Podcast. Now these files shw as empty on the player BUT some shw up in the Artists, albums, artists, and genre files. Not all thugh. 

When I connect it to my computer, the clip itself says it is almost full, but all of the files are empty.

I’ve tried pressing down the power button for over 20 seconds and it won’t reset.

I’ve tried downloading the firmware zip file and installing to the root directory. It updated the firmware.

I’ve tried putting it in USB mode MSC, pressing down the center button and connecting it to my computer.

Nothing seems to work. Any ideas please?

Thanks in advance.

I guess your files aren’t properly tagged. You could format the player using the player’s menu(settings, system settings, format) which will delete the files on the player.

You need to edit the files on your pc, and properly tag them, then copy them to the player again.

The free program mp3tag is very helpful for tagging files. The player needs id3v2.3 iso8859-1 tags.