Clip+ doesn't shut down cleanly and can't drag and drop

Hi. My wife’s clip+ has developed an issue. It froze while she was listening to it. It was reporting around 2/3 battery left.

A reset allowed it to turn off and then I tried a firmware update (from 1.01.?? to 1.02.16) which appeared to work fine, although I had to install it manually because the updater refused to acknowledge 1.02 existed.

Now after the firmware update, it will turn on ok, but I am unable to transfer anything to the device and when I try and turn the clip+ off, it freezes and requires a reset every time.

I have tried removing the drivers and reinstalling them (ok, but still can’t transfer).

I have tried both types of USB without success.

Extra info:

  • The Clip+ reports it has a full battery (which given the time it has been charging is as you would expect), but the windows interface page when connected in MTP mode reports 0% critical. Which should I believe?

  • We don’t have any mp3s - we only use FLAC files with native FLAC tags.

Edit: against all odds, while I’ve been typing this, and turning it on and off (which I have been trying for a few hours now!!) to make sure I got my facts right, it has started working. So if anyone has any ideas why this might have happened in the first place and how to avoid it in future, please do tell. Many thanks.

And since I realise that most people probably only sign up on here to get help or complain, I’d like to say that apart from this hiccup, this device has been absolutely great. I have one too (with Rockbox which I haven’t put on her one). The ability to play FLAC files and have a decent battery life (even without Rockbox), combined with the fantastic light weight and sturdy belt clip has made it absolutely perfect for our needs (running).