Clip+ dead, dying, fighting any kind of resuscitation

I have a 4GB Clip+ I picked up in December, I’ve had great success with it and I really like it. It’s been kept clean and dry and mostly at room temperature; I haven’t had it long enough for it to go through the wash, get slobbered on, stepped on, or otherwise abused. At worst, it spent some quality time under my pillow with me snoring away.

Yesterday it started having trouble and froze at the Goodbye screen. I didn’t have the manual handy (I was on a plane - the worst time for a music player to die) so I left it for a few hours until I got home.

Since then I’ve tried removing the secondary card, many many resets, multiple reformat attempts (one success in 6 attempts or so, both from the player and from XP), multiple firmware upgrade attempts (all failed), I’ve tried connecting it to the PC while holding down the middle button, and all I have to show for all this is sore fingers and a lot of wasted time.

At this point it takes about 20 attempts to even get it to boot and most of the time it simply hangs at the logo. I strongly suspect the filesystem is corrupt/in an unknown state but I can’t get the device to a point where I can reformat, let alone have the format successfully run to completion.

My goal is to reformat, check the filesystem with chkdsk, upgrade the firmware, then test with some known good songs. I am not hopeful.

So here are my questions:

  • How long should booting take if the filesystem is corrupt?
  • If the filesystem is corrupt, does the player try to format it on boot (thus explaining the boot delay at the logo)?
  • If the player “hangs” at the logo, how long should I wait before assuming it’s locked up and resetting it?
  • How long should formatting the filesystem take on a 4GB clip?
  • Is there anything else I should be doing to diagnose or recover from this problem?

As I said, I really like the Clip+ and I understand I might have to reset the device occasionally. I just wish it’d cooperate and get its act together.

Sorry if you already answered this and I missed it (long day) but is it recognised by the computer?  Either through normal connection or when holding the center button and connecting?

The good news is, if worse comes to worse, you’re covered by warranty.  In the U.S.:  1-866-SANDISK (726-3475).  Other SanDisk contact information:  http://www.sandisk.com/sandisk-support/contact-us.

Sometimes it’s recognized though it happens less and less as time goes on. I have been able to get it to mount as CLIPP (a raw drive) though formatting fails via Windows Explorer.

FWIW, I’ve managed to get it to boot again (reset from locked-up-at-logo state followed by a second reset followed by power on.) It locked up during shutdown and I expect that’s because it failed while writing preference/state info to the corrupted filesystem. I have a format going now but I have no idea how long I should wait for that to complete before giving up on it as hung. :confused:

Life’s too short - I’d replace it.

Yeah, I figured that was the answer; I just wanted to make sure I’d taken every reasonable step to recover it before trying to RMA the player.

(Also: Tried two different PCs, two different USB cables. Still DOA…)

I bought my 4GB Clip+ last week, and it’s in a similarly tragic state. It worked gorgeously for 5 days. Today, it won’t re-set, won’t turn on, won’t re-charge, won’t get picked up by three different computers and two different cables. I’m now thinking about getting a replacement, but saw your question so thought I’d check to see how you went and whether you managed to breathe some life into it?

If the Clip+ freezes, it won’t communicate on the USB bus, charge, or turn on.  Simply put, the Clip+ never really sleeps, it hibernates.  A program halt will make the Clip+ “play possum”.

Try resetting the device by holding the power button depressed for 20 seconds or so, release, then try powering up again.  If in doubt, try again a second time.

Let us know if you have any activity!

Bob  :wink:

@neutron_bob wrote:

…Simply put, the Clip+ never really sleeps, it hibernates.  A program halt will make the Clip+ “play possum”…

 

Bob  :wink:

So it’s always ‘on’ and consuming at least a little battery…?

jsmaye wrote:


@neutron_bob wrote:

…Simply put, the Clip+ never really sleeps, it hibernates.  A program halt will make the Clip+ “play possum”…

 

Bob  :wink:


So it’s always ‘on’ and consuming at least a little battery…?

Interesting question…

That’s right.  In ultra low power mode, the device draws very little.  The Device can sit idle for six months or more (I’ve only tested them at this point) with plenty of reserve power to restart.  I started with a Clip with about half-charged.

I’d venture that the draw is in the order of microamperes, so I’d need a very sensitive test rig.  You have my curiosity piqued there.  Current draw will be similar to a digital wristwatch, but even a watch is feeding current to its LCD display.

Bob  :wink: 

Oh, believe me, I’ve been resetting the device regularly. It’s at the point where it rarely boots (i.e. I cannot reliably get it to boot by any pattern of resetting or waiting.) I need to make some time to call in for an RMA. I generally don’t like calling for support unless I know something is far beyond my capacity to fix. I don’t like driving up my vendors’ support costs plus I feel like an idiot if there was a simple resolution I missed.

By this point I think I’ve tried everything I can, and I need to punt to the home office.

I’m not soured on the Clip+; these things happen.