Clip+ dead but PC sees a drive? Help!

I’ve had my lovely Clip+ for quite a few years, but it still worked great, no problems whatsoever (apart from smaller battery life, as it happens).

Yesterday, I tried to turn it on but nothing happens.

I’ve since tried the following, to no avail:

  1. Pressed power button for more than 30 seconds.

  2. Pressed power button + select button for more than 30 seconds.

  3. Plugged it into charger - nothing happens, not even after a while.

  4. All of the above with the SD Card removed. 

When I plugged it into my PC, the screen doesn’t light up BUT I get a Windows message saying “You need to format the disk in drive H: before you can use it.” It also shows up in File Explorer as a “USB Disk”. 

Out of desperation, I also tried choosing the option to format it, but Windows says something along the lines of it being a read-only disk. 

The above happens no matter whether there’s an SD Card in the Clip+ or not.

I know it looks bad, but is there anything else I could try? I love the tiny size and handy screen of this device and don’t want to part with it just yet - everything else out there is too large and/or doesn’t take Rockbox. 

Do you have Rockbox installed on this player? If so, try booting into the Sandisk firmware & see if that makes a difference. It’s been a while, but if I remember correctly, you hold the rewind button while turning it on until the Sandisk firmware comes up.

I do, and I just tried. No luck, screen won’t show anything. No indication of any activity… 

Thanks for trying. I guess I’ll have to come to terms with not being able to revive what was the best mp3 player ever. 

thanks a lot 

ثبت نام دانشگاه سراسری

مشاوره تحصیلی

دفترچه ثبت نام دانشگاه علمی کاربردی