Clip+ connects but won't mount on Mac 10.3

I bought this as a present and am trying to get it set up, but it won’t mount on the desktop. I’m running Mac OX 10.3, I’ve repeatedly gone into system settings to change the USB mode to MSC.  It was fully charged the first time I tried it, it’s been a little less than full the last couple of times.

This is the second non-iPod mp3 I’ve tried this week.  It seems like with these things, the more features it has, the less likely it will work under MacOS. Any suggestions before I take this back to the store?

Thanks!  

You might want to do a search (search box at upper left) in the Clip forum–I know that I’ve seen various “how to get the Clip to work with a Mac” tutorials there. 

Have you had any success yet?  I bought two of these for my kids for presents and I can’t get either one to mount on the MAC. I’m running OSX 10.3.9.  I’ve changed the settings but to no avail.

Mounts on 10.5 for me, visible via Finder as a drive. I have other issues with DRM protected book files, so can’t say more. Will play mp3s fine.

I spoke with a rep about my Clip+ problems and was told that when tested they found that it only worked on a MAC sometimes.   I’ll be returning the 2 that I bought to BestBuy and buy a couple of Ipods.

Never did get this to work, sandisk tech support says I have a dud, I’m thining it just doesn’t work.  Now looking for another mp3 player.

My new Clip+ works fine on 10.5.8, I wonder if the issue lies more with the OS than the player.