clip 8b hung up

hi

my sansa clip 8gb just hung up, reset doesn’t work. display is dark, only the"clickwheel" is glowing… doesn’t react to anything… updated firmware yesterday. any suggestions?

thanx!

Just curious, have you held the Clip upside-down yet while powering on/off - or is that what you mean by reset?

upside down? well just tried it, but didn’t work (and it would have surprised me if it had worked…)

by reset i mean holding power on/off for 15 seconds, as described in the manual… even held it for 30 seconds…

ok, after the battery was empty, which took about 10 hours with only the clickwheel glowing, it seems to work again… but this isn’t really a solution if this happens more often… don’t wanna wait for 10 hours + a few hours recharging every time it freezes…

Well, hopefully this was a 1-time event.

You may want to reapply the firmware (see sticky thread at the top of the forum); a computer bit may have gone wonky (that’s the technical term for it …).

gonna do this, thanks :wink: