Clip 4gig -- long netlibrary books stutter -- Format doesn't help

I purchased my 4 gig Clip specifically to listen to audio books downloaded from Netlibrary. I updated the firmware and appreciated the bookmarking feature.  I loved the Clip until I tried to listen to longer books.  Somewhere around 5 or 6 hours into a book the voice started to stutter.  Annoying at first, but soon so bad that I couldn’t listen any more.  Searching on this site I noted that formatting the Clip helped some people ---- unfortunately not me. I contacted support at Sansa through the website.  Over a period of several emails I was instructed to format three times, upload the newest firmware, download another book to try, download using a different computer, test to see if the book stuttered when played on the computer (it did not stutter)  and check to be sure that both my os and my Windows Media player were all appropriate and up to date — I think that covers it!   I did ALL of that.  Then support responded ------

“We will have to exhaust all troubleshooting steps first before we can process a replacement for your device. We do apologize for any inconvenience this may have caused you.

This is our next and last step. Let us apply the Revision 2 firmware.


If this will not work, I would gladly process a replacement request for your device.”

Because I have read on this forum that you can’t put revision 2 firmware on a revision 1 clip, I knew that this step would not work, but not wanting to argue, I tried it anyway and of course it did not work.  I went back to the support page to report my results and found that my request was closed!!!  I tried to respond and was ignored.  I tried to open a new support request about the issue and was ignored!  To say that I am frustrated is understatement.  I have to suspect that someone (whose name I will not mention) wanted to get a good close ratio and pretended that the issue was resolved. It’s not, and I am very unhappy with SanDisk support.  So here I am, hoping someone on the forum can help.  Thank you very much.

just from some experience on another device, it still might not be the fault of clip hardware. audio files can be full of errors, and some software is more tolerant of them. obviously a big pc can afford to have a lot of error tolerance, whereas a little player has less room/budget for error tolerance logic.

you didn’t say if it happened on more than one long book, but I have noticed when encoding video files that the longer ones are more fragile in terms of forcing errors. not sure if that is because of virtual memory gets filled, so less optimization is done, or what.

my support request is ignored for about 2 weeks now… that’s how good sandisk customer support is i guess…

i will never buy their products again, even if it’s just a memory card.  :neutral_face:


I’m sorry to hear that you’ve been running into issues, on both fronts.

You’re most likely running into a problem reading the Netlibrary file from memory.  The NetLibrary file is secure WMA fiormat as well, which requires more processing.

How about some Sansa magic?

First, you can update the firmware later with the correct revision.  Let’s get rid of that st tt u tt e rr first!!!

Back up your music on the Clip first (copy your music files over to the PC if you don’t have a backup of your music).

On the device, go to Settings > Format > Yes.  How simple was that!!

What we just did was format the device with 32KB cluster allocation, optimum for your Sansa.  The stutter is caused by delays in locating your audio track, listed in a huge File Allocation Table (FAT).  If the Clip is, at one time, formatted with 4KB clusters (windows loves the teeny ones), your files (music or books) can encounter issues at the midpoint of the file, getting worse until a l  l l y   ou     h e aa r   is st st  st…as you have seen.

Well, go ahead and retransfer your NetLibrary book, and enjoy the words without the stuttering drama!

I see in your title that “format doesn’t help”, but not all formats are created equal.  We want 32KB clusters. We can check the cluster size if the Clip is connected in MSC mode (settings > USB Mode > MSC). 

To run chkdsk, first verify the drive letter assigned to your Clip by using Windows Explorer.  Let’s assume it’s E: for this discussion.  In the Run box, enter cmd <enter>. An MS-DOS box will open up.  Welcome to the Matrix.  In this box, enter chkdsk E:

Look at the line regarding the allocation unit size.  It MUST be around 32000 bytes.   If it’s 4K, there is your problem.  The Sansa should default to 32KB, which is the optimum.  Go ahead and close that box.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 04-14-2009 06:12 AM

@gtherion wrote:

my support request is ignored for about 2 weeks now… that’s how good sandisk customer support is i guess…

i will never buy their products again, even if it’s just a memory card.  :neutral_face:

Welcome to modern companies and email …  Did you telephone them, for immediate help?

Indeed, the regular e-mail must need a stamp too.  Call Support at 1-866-SanDisk, as the system is geared to assist you via phone fastest, then a close second is via the Register > e-Box method.

To register your new Sansa, click on the SanDisk logo in the upper left, then Support.  You’ll see the register / e-Box signup next.  This makes a handy way to keep track of all correspondence, and your Sansa.

Bob  :smileyvery-happy:

“daft” asked if the stuttering happened on more than one long book.  Yes, I tried three different long books and had the stuttering problem on all of them at some point after 5 or 6 hours into the book.

Thank you Bob for your input. 

Chkdsk reports no problems and the following info:

type of file system   FAT 32

4,097,769,472 bytes total disk space

32,768 bytes in each allocation unit

125,054 total allocation units on disk

86,160 allocation units available

It appears that the allocation unit size is not my problem.  BTW - I did not reformat again tonight (knowing that I had already done so several times.)  Decided to use chkdsk first and only try formatting again if the allocation unit size was inappropriate.  I think I must have a different problem!   Any other suggestions?

Incidentally, the version is V01.01.30A

Thank you!

I have now updated my firmware to 01.01.32

Any other suggestions?

I would love to be able to hear long books.