clicking / stuttering in long audiobook files


I recently got a new 8gig Fuze (with the latest firmware) and I’m running into my first trouble with it. I notice that when listening to an audiobook from NetLibrary, once you hit the 3.5 hour mark (approximately) you begin to hear a clicking in the audio. The odd thing is, when the backlight is on, I don’t hear it. However, as the time increases the problem becomes more pronounced and it gets to the point where you cannot listen to the audiobook.

The book I noticed it in first is about 8 hours long total and the CD quality WMA file (the one I used) is 109 Mb in size. I tried other books and the same problem exists, first showing up between 3.5 and 4 hours into the story. The thing I have not tried yet (I’ll do so after I post this) is to download the smaller sized, radio-quality WMA file. The other thing about this problem I need to mention is that my audiobooks are stored on an external 2Gb MicroSD card (not in internal memory). I’m also going to test transferring them to internal memory to see if that helps.

Has anyone else noticed this? I searched the forums but didn’t find any other mentions of it. Could someone else give this a shot and let me know if they experience the same? I guess my other question is, should the Fuze be able to handle a file of this length without such a problem? Has anyone had issues with external memory cards like this? Ay help or guidance is extremely appreciated.



Message Edited by pr0ph3t on 07-27-2008 01:22 AM

Message Edited by pr0ph3t on 07-27-2008 01:24 AM

Bingo.  You are not alone in this interesting glitch, so fear not.  First, I can assure you that the problem will disappear if you select a lower bit rate.

This issue has plagued me only with wma files, with the sister player, the e280v2.  This wma decoding issue drove me nuts with the v2 and wma (they must be DRM files as you have) files.  It appears to be isolated to the high capacity (8GB)devices only at this point. 

I listen to Audible .aa files at 64KBPS, or Audible Format 3.  This compromise between audio quality and file size is ideal.  Audiobooks at this rate seem to avoid the dropout issue.  While hearing the sound, which will begin at the halfway point of the file as a click, it will progress to a dropout at 2.5 cycles per second, making the files unlistenable near the end of the file.  Long classical music tracks first revealed this issue.

In my v2 case, I have found that loading the identical music track on the µSD card avoids the issue; I simply load the album, and tracks longer than about 8 minutes go on the card, off the internal memory, where the v2 has this issue.

Please clarify the internal versus µSD card issue.  Are you sure that the noise is occurring on tracks loaded on the µSD card and not the internal memory?  I need to clarify that.

For right now, see if you can load your audiobook at a lower bitrate, and let us know how it sounds.

Bob  :smileyvery-happy:


Thanks for your response. I did the test whereby I moved the WMAs from external to internal. The clicking went away. It sounds like the opposite of what you’ve found on the e280v2. Odd. I’m just using a standards sandisk micro SD card. I wonder what I’d see with a microSDHC card which the Fuze will accept.

As far as my test with the lower bit-rate version, it turns out that NetLibrary doesn’t allow these to be transferred to devices. You can only transfer the higher CD quality protected WMA files. I’ll have to find something else to do that test with.

Again, thanks for your response. At least I know I’m not completely alone.


If the filesystem of the card is fragmented, there can be delays in fetching the content fast enough,  esp with a very long file.

I would try formatting the 2 GB card as FAT  (Not FAT 32).  FAT 16 filesystem is less overhead on smaller cards. This may help the situation immensely.

Likewise,  reformatting the internal storage using the devices format command may also clear up the fragmentation enough to make the the problem go away.

A solution to the problem on the devices firmware side can also be to raise the clock frequencies while decoding with the backlight off,  however this will shorten the devices battery life.  We are working to resolve this problem on future firmware releases. 


Update:  We have found that Formatting FAT32 directly in XP under MSC mode may cause this problem.  The Default FAT32 Filesystem cluster size is set to 4K under XP.

You want to use a larger cluster size, such as 32K. Small cluster size results in a much longer Filesystem FAT search because the number of records is very large.

This can slow the player down when seeking / playing very long Audiobook files. 

The best way to format is to use the devices own format command  under Settings>System Settings> Format.  This will ensure the optimum cluster size is applied.

For 8 GB external cards,  I suggest to use the DOS command line (Start>Run>cmd)  and format them as:  Format [drive letter]   /FS:FAT32  /A:32K

For 2 GB cards and smaller,  Format    /FS:FAT 



Thanks a million. I’ll give this a shot. I truly appreciate the awesome support. What a great bonus!


i saw this post a while back and ever since i’ve been accutely listening for clicks

and i finally heard them this AM when listeing to some .mp3 audio files. :frowning:

i have an 8GB model with v01.01.11a firmware

i used the format command on the device last week and then i have been dragging audio files to it in MSC mode.

everythign is on the internal memory, i’m not using an external card

i had been listening to an album for @ 50min when i noticed the clicking.

i thought maybe the heaphone cable was the issue so i removed it and replugged and the clickign was still there. 

so i stopped it and switched to a different song and the clicking was gone.

then i went back to the same song i heard the clicking and it was then gone

definately a little concerned about this…


My issue went away when i followed the advice of sansafix above. Do you have the album as one big file? Is it on an external micro sd card? Or internal memory? Did you ever reformat your device using the O/S fat32 format? If so, i’d definitely try the suggestions sanfix provided. They worked for me. I guess the other question is, if you xfer this file to a pc and listen there, does it reproduce the clicks?


The clicking, when it occurs, isn’t a subtle issue heard in the background, at random.  I wouldn’t fret about it, as formatting the device via the onboard Format command will optimize the memory with 32KB blocks. 

I’ve found that loading longer files onto the µSD card was quite simple using Rhapsody.  I simply looked at the song durations on several classical albums, and had the client load the longer tracks onto the µSD card instead of the internal memory (where I had the fragmentation issue).  The cool part: the Sansa automatically lists the entire album, and inserts the files from the µSD card without requiring any intervention on my part!

Formatting the internal memory solves the problem.  I’ve found that, as much as I use this device, it’s a great idea to “clear the deck” every now and again anyway.  While she’s charging, I can reload to my heart’s content.

Now get those earbuds back on!!

Bob  :smileyvery-happy: