Cellular data

Is it normal that I have to turn off “Cellular Data” on my iPhone 4 for the MWD to operate in Wi-Fi?
I can use my home Wi-Fi with “Cellular Data” on my iPhone with no problems. Why not with the SanDisk Media CC## ?


In the First version of the WMD app and Firmware if you were connected to the WMD WiFi it would not connect to the internet via cell.  this was changed in the latest versions of the App and FW so make sure you update. the latest version will keep the cell connection even though you are connected to the WMD WIFI

When was the latest upgrade done?
I just purchased my SanDisk two weeks ago. When I installed it, I checked for updates and all was okay.


check the FW latest is 2.93. It seems you will need at least iOS 7 or higher to get the feature.


Firmware version 2.93 Release Notes

New features

  1. Setting the DHCP server to empty if Media Drive is not connected to a WiFi access point. This enables iOS 7 and higher users to connect to a cellular data network and to the Media Drive WiFi network at the same time.

I have version 3.03 and running 7.1.2 (11D257) on an iphone4

Could it be a problem with my settings?


3.03 is the app version not the WMD firmware version. You will need to connect to the WMD and log in to the admin settings. There will be a option for upgrade media drive with a number beside it. That number is the WMD firmware version. If you do not have 2.93 you do not have the latest FW. You can upgrade the FW using the link i previously provided. 

The firmware is 2.93. I also taped on it and it said “Searching for upgrade” …“you are running the latest firmware”.
What now?
Sorry to be a pest. I just don’t want to miss a phone call while I’m using my WMD.


Hey! I got it to work. What I did was to keep my cellular “on”. However, I turned my 3G “off”.it worked. I could use my phone and the WMD at the same time.ni then turned my 3G back “on”. Everything was still working. Now I logged out of the SanDisk app and logged back in. Everything is still working fine.
I really don’t understand the “Why”. But it works and that’s all I wanted .


Just an update;
When I turn the WMD off and then back on again, I need to repeat previously mentioned steps. That is, I leave my cellular on. However, I turn the 3G off putting the iPhone cellular in LTE. Now I turn the app on and everything is fine. I can even go back to “settings” and turn 3G back on with no issues. It seems that I will need to always turn off 3G before connecting to the app using Wi-Fi. Then I’m good to go. This only applies to my iPhone 4. Both my iPads are Wi-Fi only.
Seems strange that I need to do that. But it works. Could be something to do with my cellular provider??