Can't See Some MP3 Files

I’ve had an 8MB Clip+ for about a year.  I use it exclusively to play MP3 files in shuffle mode and it has worked well.  I initially loaded about 300 MP3 files on it.  PC runs Windows XP/SP3 and Windows MEdia Player 11.

A couple of months ago, I plugged it in to my PC for routine battery charging and my PC (same computer, nothing new) would not detect the Clip+ device.  After consulting the user manual, I changed the Clip+ USB setting from “Auto Detect” to “MSC” and that cured the non-detect problem.  I then transferred about 30 additional MP3 files to the Clip+. 

NOW, when I plug the Clip+ into my PC, I can only “see” those 30 recently-added MP3 files (regardless of the USB setting).  I can’t see the original 300 files - yet they are still there and play fine (along with the newer files) using the shuffle mode.  Can anyone tell me why my PC can no longer “see” all the files?


Found the answer in an early posting reply by “sansafix” (thanks!):

Seems that the Clip+ will only let you see files that were ADDED while in MSC mode if your Clip+ remains in MSC mode.  To get it working again in “Auto Detect” mode, do the following:

1.  Set the Clip+ to USB setting “Auto Detect” and connect to PC USB port.

2.  Use the PC Device Manager (Go to Control Panel, Then System, Then Hardware) to delete the Sansa Clip+ Device from the PC hardware settings.

3.  Disconnect the Clip+ and reboot the PC.

4.  Reconnect the Clip+ to the USB port and the PC auto-detects it.  Now it works fine in “Auto Detect” USB setting and “sees” ALL the files.

Thanks again, “sansafix.”

it could be the old MSC-MTP USB mode issue: your computer only sees the files on the Clip that were transferred to the Clip using the USB mode that your Clip then is connected to your computer under. And when the Clip’s USB mode is set to Auto, the Clip will try to connect in MTP mode but then will fall back to MSC mode, if unsuccessful with MTP mode–possibly leading to a mix of MTP and MSC mode files on your Clip. And so you might try switching to the other USB mode and see if the files then show on your computer. And to clean matters up, you then could transfer the files to your computer; detach the Clip and reset its USB mode to MSC mode; and then reconnect your Clip to your computer and re-transfer the files back to your Clip (and then keep the Clip on MSC mode forever more!). Hope this helps–

Ah, we were posting at the same time. As to your solution, while it can work for you, it also still can lead to issues, with a mix of MSC and MTP mode files, depending on the USB mode connection at the time (or through the use of different computers). Hence the reason why some of us prefer to avoid the Auto USB mode like the plague and either set to the universal MSC USB mode or, if needed because you have files with digital rights management, MTP mode.

Thank, Miikerman.  You’re probably right - when I first got the Clip+, I just started using it in the default “AutoDetect” USB mode.  Didn’t know any better.

Like so many things computer, Auto works great, when it works (as you want it to).   :wink: