Can't play split MP3s

I’m totally new to all this. Have new 8GB Sansa Clip+ that I use primarily for radio podcasts and it works fine for this purpose.

However I also have a bunch of MP3s that just won’t play. All used to play on my (now defunct) Sony Walkman.  Still play OK on my PC and Android tablet.

These MP3s were originally derived by making a file from a vinyl LP and then using Direct WAV MP3 Splitter to separate out individual tracks.  The complete file of the LP plays OK on the Sansa, but the MP3s of the tracks won’t play.  I see them listed but when I attempt to play them they just skip.  Tried stripping out all tags on a test file using MP3Tag but no joy.  Updated firmware just in case.

Answer probably obvious to those in the know but it’s not to me.


Just to be sure:  are the files in a format that the Clip supports?  And not DRM-protected?

Thanks for responding.  The test file I’m playing about with is 128kbs ID3v2.3.  As far as I can tell there are no other tags that should stop it playing including DRM.

The origin of the file is an LP vinyl played on my my ancient Technics deck with the analog output routed (phono) through a MUZBOX converter, Then subsequently the whole MP3 of the LP was split into individual tracks using Direct WAV MP3 Splitter.  Can’t see how DRM could be introduced in this process.

I’ve also tried reformatting the Clip, more in desperation than expectation. Still no joy! At least my test file keeps me amused - Bob Newhart’s The Nudist Camp.

Skipping past the files indicates the Clip doesn’t think they are in a readable format.

Get mp3tag and see if it will just fix the mp3s.  Just do one as an experiment.

Let it add itself to context menus while installing. Set its Write defaults to ID3v2.3 ISO-8859-1. 

Right-click on the folder, choose mp3tag from the Open With menu, highlight all the files and Save tags. Maybe your splitter introduces a header or something the poor little Clip can’t understand, and with the correct Write option mp3tag will fix them. 

Also, if these ever had anything to do with an Apple computer, make sure you actually have the files on the Clip instead of the MACOSX folders full of 1kb finder files–which also have the mp3 extension. 

It gets curiouser and curiouser.

Testing with two files, one that plays and one that doesn’t.  Both show identical tags specifically ID3v2.3 ISO-8859-1.  Blowed if I can see what the difference is although there must be one.

The only difference I know of is the way they were generated - the one that plays was a straight conversion from my record deck playing an LP.  The one that doesn’t was the same thing BUT subsequent to the initial conversion I split it into individual tracks.

Ah well - it’s a good way of passing a wet Sunday.  PS Never been near an Apple.  Thanks for advice.

Might want to try a different mp3 splitter program.

Incredibly frustrating and I can’t figure it . . . .  Perhaps try SanDisk Customer Support (although this seems eons over the typical Customer Support question)?

One thing to try:  re-save the files under MP3Tag–sometimes it fixes things we have no idea about, and it’s just a button press. 

To conclude this topic I thought it would be polite to post the eventual outcome. I tried everything I could think of by way of tags ect but never succeeded in getting any of my split MP3s to play.

Then a week ago good fortune took a hand – I won £108 on the lottery :smiley:(someone up there must have been trying to tell me something) which I spent on a Sony NWZ-583 and a case to go with it. The Sony plays all my wayward MP3s. These Sansa, is great for my pod-casts – in for pod casts it beats the Sony.

Thanks to all who tried to help. I shall continue to mess about with the MP3s as a sort of hobby and maybe eventually I’ll find out why I can’t get them to play on the Sansa. If I ever do I’ll come back and post what the problem was.


Congratulations–good fortune to you!    :slight_smile: