Can't load audiobooks

I purchased this to listen to audiobooks on the treadmill & can’t get that function to work.  Podcasts, fine. Audiobooks, no…  I’m using OneClickMedia via my local library to download Recorded Books.  I’ve changed my USB mode to MTP based on advice from OneClick Media.  I’ve tried drag and drop, but my Audiobooks folder remains empty. Help!

What format are the audiobooks? If they are protected WMA, you need to have the player in MTP mode, and use Windows Media Player or some other media player to transfer them to the player, so the licenses transfer.

I never used One Click Media. Perhaps you might need to transfer the files to the player using their program.

Am not familiar with One Click Media, nor the Zip, but have similar experience with OverDrive Media Console (a similar library audiobook loading app) and the Fuze+. 

During transfer using One Click Media, perhaps it’s loading into folder location “\Music…”?  This is what OverDrive patrons face, and we have to correct by taking steps in the loading app (OverDrive Media Console app, or OneClickMedia in your case) to force the files to load into \Audiobook…

I have a similar problem.  Using Overdrive I try to change the download directory for books from Music to Audiobooks, but the player won’t allow the app to save files there.  I can save them to the Music directory.  But I can’t move the files from Music to Audiobooks, it’s as if the directory is write-protected.  I tried it using file manager.  On Windows Media Player it doesn’t even show the Audiobooks directory.

If I can’t figure this out soon I’m returning the player.

I’m assuming in Overdrive Media Console, during “Transfer”, you’re selecting “Advanced Options” to type in “\audiobooks” manually (I usually type “\audiobooks\BookName” to keep it organized & Overdrive creates the “BookName” folder automatically).  What happens to prevent it from writing to that location - any error messages, etc, which might help identify the issue?  In File Explorer, can you manually copy any miscellaneous file to the audiobooks folder or does that act write-protected as well?

Windows Media Player doesn’t know about the audiobooks folder, so it can’t copy files there. 

I don’t have any problems with Overdrive & ClipZip.  My only issue with ClipZip & audiobooks is the display (lack of track numbers).