Cant install recovery tool on vista

When ever i try to install it i get an error saying DPinstal something like that, I tried to install it running it as administrater and it still didnt work.

Any help would be appreciated.

try this- connect high speed to sandisk (not dial up) and download again the reset utility, this time instead of saving the file select run.

I have the same problem. My Connect needs to be recovered, but this won’t load. I tried saving and running and got the same DPInst error both ways. Is this just not compatible with Vista? It began hanging up on the boot about a month after I got a new computer running Vista.

I had this same problem… the recovery tool would not load on a Vista system, regardless of what I tried.  Finally I tried it on my netbook(running XP), and it installed and loaded just fine.

It seems to be a conflict with Vista.

I have made the recovery tool work with Vista on the no-wi-fi Connect.  But there have been a spate of similar posts lately about not being able to make it work.  So in the off chance that the official Sansa Connect Recovery Tool has gotten corrupted somehow, I have uploaded the version of the tool and instructions that worked for me here.  Don’t forget to follow the instructions to the letter.  I succumbed to not doing that once, going a little too fast and missing something vital.

Message Edited by jj2me on 06-20-2009 11:22 PM

@jj2me wrote:
I have uploaded the version of the tool and instructions that worked for me here


“The file link that you requested is not valid.”

Thanks.  Link is fixed now (I hope–hard to tell if the permissions work for others, because it’s logging me in automatically), and repeated here.  I messed up the first time on activating the link.

Message Edited by jj2me on 06-20-2009 11:26 PM

Thanks …

I did a binary compare of your file to the one at; they’re identical.