Can't get to 'Recovery Needed'

All, I got one of the infamous white-box no-wifi units, and found the excellent directions to back-rev the firmware, but I Can’t Get It To Go Into ‘Recovery Needed’ mode! 

I’ve held down the power button for 8 seconds, 20 seconds, 30 seconds. I’ve followed the instructions about holding down the ‘Right’ button (under the screen) and the Volume up button simultaneously while restarting, about 50 times, and it simply restarts the player. Is it supposed to get to the point where the colored balls show up on the screen? I’ve tried holding down right and up all the way through that boot-up, but I suspect by that point it’s already past the place where it should say ‘Recovery Needed’. I’ve tried it plugged in, unplugged, everything I can think of. Am I missing something? Did they change the firmware? I’ve got the same versions as listed other placed in this forum: ZAP: and OS Boot loader 24655, if that matters. 

Any ideas?


Weird.  I had the same versions as you.  This wont be helpful because I’m basically rewriting what you already read, but I’ll do it anyway because it’s exactly what I did.

I held down the power button for like 8 seconds until it completely shut off (I believe it says goodbye or something instead of sleep mode…)

I held down the right button on the face and the volume up on the left side at the same time, and pressed the power button once quickly without holding it

i continued to hold down the right and volume up buttons and it seemed to take like 15 seconds before it really turned on fully and it just displayed the message recovery needed and nothing else

once it said this i could not go back into normal mode so its not like something youd miss

its stuck there on the screen even if you reboot it

unelss you recover

You may have a non-working right button.  Just a guess, I had one like that.  Hard to test, because I think the right button only has use when on wifi or setting the WEP password.  Again, just a guess.

Update: I finally got it working. Just kept trying. Eventually, it seemed like I pushed the Right button about a quarter-second after the power button, but once I got there I didn’t take any chances, I downgraded the firmware and all was well. 

I like it so much I went back and bought 2 more! Thanks for the help from this site.



Okay I have the same issue…so where did you get the firmware to down grade the “Sansa Connect” to get WiFi?


PS My player is needing the recovery program.