Can't Download/access Sansa Fuze

It started out (2 weeks ago), I couldn’t get mediafly to sync with my Fuze, it would lock up.  Last weekend I tried updating drivers and running updates, using different USB ports (though I don’t know why that would help) with no success and eventually got too ticked off to continue after Windows would lock up.  This morning I tried to directly copy an mp3 over in windows, and the file transfer froze.  When I tried to re-open the Fuze in Explorer, it “searched” for the files/folders and then completely closed explorer.  I went back into Explorer and it doesn’t even show my Fuze connected.   Ideas?


Imo I think that it is your computer and not the mp3 player that is the problem here, if you can’t connect other devices either, I would suggest taking your computer to a specialist to fix it… or ONLY if you are really desperate Save all of your important files to another computer(or any other place that isn’t part of your hard drive) and the wipe your memory clean and reinstall your original operating system, then update everything, blah blah, you get the point. ( I’ve had to do that before so don’t laugh, I spent all day reinstalling every game, program and accsesories again) But I’m not responsible for what you end up doing to your computer…btw It might say I’m a newbie, but I’m not a noob, there’s a difference

In regards to it being a computer issue, I tried on another computer and same thing, I can’t get files onto the Sansa.

When you update the firmware it switches the default USB Mode (under Settings/System Settings) to Auto Detect. Switch it to MSC, the most basic USB connection, and see if you can connect.

Then, if you can, right-click on the first driveletter (the Fuze’s internal memory), go to Properties/Tools/Error-Checking and run Error-Checking.  There might be a bad file on there.

Oh, and by the way, Mediafly says “Sansa e250 and e260 will not work if Rhapsody or Windows Media Player are running.”

Changing USB ports can help, incidentally, because different ports provide more or less power, and because other devices recognized through a particular port might interfere. 

You’re going to have to switch to MTP to use Mediafly, but the important thing is to establish a connection for starters. 

Message Edited by Black-Rectangle on 09-20-2009 09:31 AM

Message Edited by Black-Rectangle on 09-20-2009 09:35 AM

If your computer isn’t even recognizing the Fuze as being connected, try this.  I had that problem for a few weeks, tried different USB modes, reinstalling drivers, all kinds of stuff.  Found this on another thread, and it finally worked: 

neutron_bob wrote:

You can try charging it up first, by connecting in MSC mode manually.  This way, you can start with a charged Fuze.

  1. Open a Windows Explorer window by pressing the [Windows key] + E, or go to My Computer.

  2. Starting with the Fuze OFF, slide the power switch to the HOLD position (orange showing).  Press and hold the center button down while connecting to the USB port.  You should hear the familiar ba-ding sound as the device is recognized, and it should show up on the screen.  At this point, release the button.

This will allow the Fuze to charge: have a look at the battery icon.  It should be strobing.  Connecting in MSC mode is an easier task for the Fuze.  In this mode, it’s seen as a flash drive.  I suspect that the MTP mode might be your problem.

When the Fuze cannot establish a connection, it can get distracted from the charging operation.  It’s best to charge it before working on the MTP part of the equation.  Once it’s charging, you can slide the HOLD switch back to the center position.