Can't Add/Remove Music From MicroSD


I am posting here because I can’t find a solution to this problem elsewhere.  I cannot add or remove media from my microsd through the sansa. The added media will show up when I first drag and drop it however when I remove the sansa from my computer and it proceeds to refresh my media, the songs are missing. The media also does not show up when I plug the sansa back in and look for the added files in the appropriate directory. The USB mode is set to MSC.  The microsd is nowhere near capacity and I have tried reformatting the Sansa to no avail. When I try reformatting the microSD itself windows says it is unable to complete the reformat so perhaps the issues lies in that? At this point I am very frustrated and don’t know what to do so any help would be appreciated.

You might try using the SD Association’s own formatter tool, and see if that works.

That didnt work

I should be more specefic.  The program you suggested didn’t work because it says the memory card is write preotected.

Is there a physical switch that write-protects the memory card? Look closely at it.

It seems the problem is with the card, not the Sansa. Do you have an adapter or a slot in your computer to just try using the card directly connected to the computer?

If you put the Sansa in MSC mode it is, essentially, just a USB connection between card and computer. So, either with the card in an adapter or in the Sansa, find the card in Windows Explorer (My Computer or Computer) and right-click on it and look at Properties. Is it write-protected? Can you un-check it?

Also, check out to make sure you didn’t get stuck with a counterfeit microSD. There are tricks bad people use to make little cards look larger to your computer. So the computer thinks its filling up a 32GB card, or whatever, and it’s really a 2GB card and has no place to store the music.

H2testW will tell you if it’s a real card. It does erase everything on the card so make sure you get anything you need off the card first.

I ran that program and it said around 10GB were corrupted but i havent been able to complete the full diagnosis because the sansa unplugs itself from the computer after around 2 hours. Is there something I can do to fix this? Also, I’ve had the sansa plugged into the computer for almost a day now yet when I took it out there was no battery in it. As both the sansa and microsd are acting eratically,it may be more helpful at this point to know what I did wrong in the first place in order to avoid something like this again if I decde to purchase a new sansa.

Also in reply to your questions, there is no physical switch on the microsd and i have been accessing the microsd through the sansa itself.

You may not have done anything wrong. It could just be a defective unit or cable. If it’s less than a year old it’s under warranty, 1-866-SANDISK , or you can Google to find service numbers if you are outside the US.

I’ve never had  a Clip+ unplug after two hours when connected–it shows the battery full when it fills up, but stays connected. That might be a setting in your computer–I don’t know. 

But if your battery is not charging…that’s a worrisome sign.

Try a different mini-USB cable.  An older camera or phone might have one. The Clip+ makes both a data connection and a charging connection, so something may have gone bad in the cable. Cable problems are not always visible.

Meanwhile, while you’re hunting for a cable, is  there any way you can make another connection to that card? The Clip+ is not the fastest connection around, so if you have an adapter, a camera, whatever, try that.

With 10GB coming up as corrupted, that card is probably a goner. But if you can connect to it–even in the Sansa–you could try running Windows chkdsk. Find the card in Computer (or My Computer), right-click on it, Properties/Tools/Error-Checking.  Sometimes Windows can do some amazing repairs. And sometimes not.