Cannot Remove Albums or Songs from Playlist

This has been making me crazy for a couple weeks.

I’ve been all over this board researching. I cannot delete the album and song titles from my clip. I had the bright idea to reload the songs that were appearing to try deleting them using a different mode and now they show up twice. I’ve tried changing USB modes. How can I get the music I remove to take the titles off too? We’re talking about several hundred songs so deleting them individually from the player itself is not practical.

What you could do is go into my computer and delete the songs/albums from there and reloading the ones you want. If you want to delete them more quickly then you could do CTR A and push delete, that deletes everything off of your MP3 player. then upload all the songs that you want again

I do use folders for adding and removing music.

You could try reformatting the Clip, from under its Settings.  Note:  this will delete all your content from the Clip.

Mikkerman, thank you; that did get them cleared off!

Unfortunately, I loaded a single song to see if I could get it on and off easily and could not find that song at all in the music; I got ‘no song’.

 Well–you’re halfway there!

I’d try:   a system re-set–Clip off, hold the on switch uppermost for 15-20 seconds; and then a reapplication of the firmware (it could have become corrupted over time)–see the sticky thread on firmware upgrade at the top of the forum.

Hopefully, one or the other will fix matters.

Miikerman, I ran the firmware update and I still get ‘no songs’ in the music folder.

Silly question, but:  are your songs compatible with the Clip?  What is their type?

I have the same problem. I originally put on a number of albums and all has been working fine. But now I wanted to remove some albums and put on some news ones, but the old ones still appear and the new one does not. I am doing this via Windows and I have upgraded my firmware.

They’re all mp3. I have no problem at all on another brand player that holds less music. Not a silly question at all, I could be a big dummy for all you know :slight_smile:

Well, we all have our moments with technology.  My favorite is my literally smacking my dead all-electronic alarm clock to get it to work–it worked.

OK, is this an MSC / MTP USB mode issue?  Your computer will only see songs/files placed on your Clip using the USB mode that your Clip currently is connected to your computer under.   Hence, a good reason to set the Clip’s USB mode, under Settings, to eithe MSC or MTP and to consistently use that (and to avoid Auto, which can use either mode). 

@chrish wrote:
I have the same problem. I originally put on a number of albums and all has been working fine. But now I wanted to remove some albums and put on some news ones, but the old ones still appear and the new one does not. I am doing this via Windows and I have upgraded my firmware.

chrish--  As noted above, I would reformat under the Clip’s Settings.  Note: it will erase any content you put on the Clip.

Thanks Miikerman - I will give that a go. But does that mean that every time I want to add a new albumn or remove an old album, that I have to reformat and start again?

No–the reformat can be useful in cleaning the Clip up, and hopefully getting rid of an issue so that it doesn’t recur.  I also would reapply the latest firmware (see the sticky thread on firmware upgrades at the top of the forum)–the firmware could have become corrupted over time.

Miikerman, that did it! It never occurred to me to check the USB settings again after reformatting! You are awesome. Thank you for you patience and for your help. I sincerely thought I had a cute little red brick on my hands. You’re my hero.

I’m glad it worked and I’m just sorry that I was asleep at the wheel–I should have thought of the MSC/MTP conundrum right off the bat …

I’m glad it worked and I’m just sorry that I was asleep at the wheel–I should have thought of the MSC/MTP conundrum right off the bat…  But, good that you got there regardless!

Still one of the cutest little players out there–