cannot get express to read 1gb pny card

    I have tried every possible combination of starting it up restarting firmware upgrades and such. it flashes and says the card is in, but no matter how long i wait it does not recognise any of the music on the card. is there a specific way ie no folders and such to get express to read my external card? thank for any assistance.

It should just work if you have the newest firmware installed.  Check under Settings > Info.  It says 1.01.05a, right?

If not, SanDisk tech support can provide you with 01.00.15F, which is an earlier version with some architectural differences that seems to have different luck concerning card compatibility.  01.01.05a works with every card I’ve tried, but I’ve heard of a couple of people that found that only one version or the other (but not both) would work with their specific card.

I just upgraded 01.01.05a and It still does not work. I dont remember what version was on it before I upgraded. is there a way i should go about using the card ie should I put the card in the express before turning it on? should the files be on the root or in a folder? and its a one gig card what is the longest it should take to read whats on the card? it does acknowledge the card is in the player but it seems to just be in the background because it only shows for a fraction of a second that the card is being read.