cannot format micro sd, believe me, i tried everything

:smiley:  Hi Deutsh,

_ Dear member of SanDisk Community, welcome. _

Please friend, do not grieve more, see link, and you might have a pleasant surprise:

To find out more on this, see here:

If you want, experimenting with possible solutions, see here:

If you are angry, and think about changing of brand, before, see here:

Enjoy!  :wink:  

Regards, Alfred.                                                  (Google Translated)

I am also facing the same problem for 4 gb sd card…i have tried all like you…

:smiley:   Hi devangchauhan,

Dear member of SanDisk Community, welcome.

Well, friend reads this page, and you will find the solution.


Regards, Alfred.                                          (Google translated)

try this step guide to format your memory card

try this link

My 64GB ultra micro sd developed this problem too, i tried everything and still can’t find a solution.  It started about 5 monthes ago i was watching a video on my Galaxy note 8.0 and suddenly the the tablet closed everything and said the memory card is corrupted.  I couldn’t access it until i restarted my note then it started functioning normally.  I noticed the problem afterwards when pics and songs disappeared after i moved them into it and things i delete are brought back. Since then I’ve been trying every way possible to format it but nothing worked.

I too wanted to share my story so that nobody else buys it until a solution is found.

I didn’t use it that long almost for only a year or less but because i bought it earlier before using it i couldn’t use my warranty any more. 

@lovely_r wrote:


I didn’t use it that long almost for only a year or less but because i bought it earlier before using it i couldn’t use my warranty any more. 

Your card has a 7 year warranty. Are you saying you bought it longer ago than that? I doubt it, since they aren’t that old.

Just called Sandisk support, and they said all their products have a 10 year warranty.  My replacement will be delivered when they get the bad one returned, which they will collect in the next day or so.  Solved!

eventhough this problem is a past few years ago. i just want to share how i fixed my microSD. i encountered all the problems that mentioned here. i tried formatting my micro to a different OSes, bunch of softwares which gve me the same error. then i said to myself i got a rooted htc phone which has an 4EXT recovery on it. i got 3 samsung device that has twrp and i never got my micro to get fix even cwm. so after almost a day banging my head trying to fix it. i inserted my micro to my old htc phone, and went to recovery, at first boot up it gve me an error that my micro sd won’t get mounted. so i just let it boot up and when i’m inside the 4ext recovery i pick format sdcard. and it won’t gave me an error. after i’m done formatting my micro i put the microsd to an adapter and check it on my linux and the red exclamation point was gone. so try it for yourself guys! goodluck!


I bought the same card. Same issue after about 2 years.  They are letting me RMA the card, and will hopefully send me a replacent. Not fun. 

Hi everyone, I am also using a Samsung Galaxy Note 2, with a Sandisk 64GB micro sd card. I am facing the same problem as you. After using the camera, the images / videos are not captured. And old images cannot be deleted even though I thought I had successfully deleted it using my phone or computer. Is the micro sd corrupt or my Note 2 has gone cranky?  

Well same thing happened to me. I tried the default SD formatter of a PC but didn’t work. I tried EaseUS partition master, SD card Formatter and so many others even Aparted on android. My friend advised me to use a java phone to format it, I put the SD card into the old Nokia C2-00 I had and it worked. I formatted it and started using the card on my phone.

My GoPro Hero 3 black has now done this to 2 of my SanDisk 64gb micro sd xc’s…

No longer under warranty… I take it niether GoPro or sandisk are gonna address the issue / provide refunds…

My GoPro Hero 3 black has now done this to 2 of my SanDisk 64gb micro sd xc’s…

No longer under warranty… I take it niether GoPro or sandisk are gonna address the issue / provide refunds…

i’ll try non-Sandisk when I go spend mo money on a new card…hopefully doesnt happen again… these cards being $50 CAD I hate to have to be buying new ones to replace faulty ones…

This fault seems to be pretty common considering… does anyone if SandDisk issued a recall for this faulty product?

Did you try formatting it from your computer? I just found a quick solution that worked for me. Check it from

New comment to an old thread but I have no idea what else to do. I have had my microSD card (64 gb) for months now and no problems until recently I turned my phone on and it said my card was corrupted and needs to be formatted. Now every time I try to format it, it starts at 30% formatted and doesn’t budge, until I finally get a “failed” message or the request times out. Tried to format on my computer but that doesn’t even register that there’s a card inserted? I can’t make sense of that. I went to request a replacement but since it’s been several months I don’t have my receipt anymore and don’t remember the date of purchase. So that option’s out and maybe I’m just out that money then?

Hello All

I´m both glad and sad upon seeing this. Seems like a common problem? I have run my 64GB micro-SDXC in my Xperia Z5 without any problems for 1yr+. 

All of a sudden, while in a call the phone froze and was totally unresponsive. I removed the card and phone works fine. However I cannot format the Card? I´ve tried through varios electronics (camera, phone) as well as my Mac and Win 7 Computer. Including the software SD-Formatter. 

Just contacted Sandisk support by mail. We´ll se what happens. 

Or has anyone found a sollution for this?

Ok, so I recently got a DJI Mavic Pro drone. This Thursday I was flying with it in the morning and filmed some very important footage. I then went to work and spent the day not looking at the footage. I now pulled up the card on my Mac OS X and it was saying that the card is not recognizable by the system. Then tried the switch in different locations, no difference.

It’s showing up on the system as a 30.6mb. And can not be formatted in any way shape or form with anykind of software or using DOS on  Windows computer which I just picked up as most data recovery or SD Format tools are only for Windows.

Well nothing has worked so far. I’ve tried 10+ different software, most of them don’t even show the card.

It shows the file system as RAW. Locked/Read only, eventhough that’s not the case. It is an San Disk Ultra 64gb Micro SDXC I 10.

Test disk says no partition found or selected for recovery.

Format on DOS says not having sufficient priviledges, even in administrator mode.

EaseUS Data recovery tool says it has 0mb data.

SDFORMATTER4 says card is write protected and can not format the  card.

My DJI app said it can not compelete a format on this card.

My Olympus OMD camera says it can not recognize the card.

My Canon 6D is also not showing the card any love.

I have been using a MicroSD adapter, I’ve used a card reader, no difference in choise of tools. I’ve also tried a few different adapters if one would be malicious, tested with other SDXC cards and they work flawlessly. Just not this one.

I’ve read countless forum posts, articles and tried everything of my knowledge and what I have learned so far except a Linux computer. I feel like if none of this did it, that might not either and I would just spend 1h installing it and then end up still not getting it to work…

Read this post by a SanDisk member earlier in this thread with no resulsts other than the card is gone. But what why how?!

And then did not find any helpful tools or tips here or here

So what happened once it was ready filming the footage from the drone?

This thread as many others looks like it’s been created a long time ago and it’s still not solved. Why is this happening?!

you can plug your sdxc card out from your phone, and insert it to a windows-based computer to check if you can format it in Disk Management or Diskpart. If all fails, you can still try a third party tool to force format the SDXC card.