Cannot copy files to Sansa Fuze using Windows 7 (drag and drop or Windows Media Player)


I bought the Sansa Fuze yesterday and I am experiencing problems copying files to the device using either Windows Media Player (Sync) or Drag and Drop (Explorer).

The symptoms are:

  1. The device is recognised and browsable in Windows 7 (USB set to MSC - sorry don’t have it with me at the moment)

  2. I’ve upgraded to the latest firmware, which worked brilliantly

  3. When I attempt to drag and drop a file to the device (I’m using Windows 7, 64bit), it starts, but does not seem to calculate the file sizes or expected download time correctly.  This is followed by a gradual slowdown, until the computer hangs, resulting in a constant 100% CPU.  The only fix is a hard reboot

  4. When using Windows WM, the device is recognised, Ok and the synch starts, but it then stops for no reason.  Again, the CPU shoots up and needs a reboot

  5. Using 3 and 4 results in 1-5 files being copied across, but no more.

  6. I’ve tried multiple albums and one album at a time, but cannot determine if this makes any difference.

Please help!



It may be a Windows 7 bug. But one thing to try is to go to Device Manager (assuming Windows 7 still has it), uninstall the Fuze (under USB controllers) and then run Add Hardware to find it and reinstall the driver.

Use MTP mode with Windows Media Player, MSC mode without. 


Thanks so much for your help.

I’m not entirely sure if it alone helped, but I followed the advice, rebooted (though, somehow, lost all music libraries in WMP),and the device appeared correctly.

I’ve not experienced any issues since - so cheers!


It is definitely not a Windows 7 bug, since I use Windows 7 and I’ve never had this problem. However, one thing I did realize is that Device Stage doesn’t work with the Fuze, even though it’s supposed to. I could still use normally with Windows Explorer, just I don’t get all the extra information.

Very often, our MP3 files are copied from one computer to another or downloaded (Save As…) from a browser.

The Windows 7 behavior I first experienced with the “Cannot copy” error was from an MP3 downloaded from a website.

When I’ve copied from a webpage through a browser like Firefox, the MP3 file is tagged “blocked”.  If you’re using file Explorer, right mouse on the MP3 file that fails with “CANNOT COPY” and look at the GENERAL tab.

If the GENERAL tab at the bottom right has an [Unblock] button right under the [Advanced] button, then Windows 7 is keeping you from copying that to another computer or device.   

It will SHOW you it’s copying it to your Sanza Fuse, but right at the end, it will fail with the “Cannot copy” dialog.

Simply click on the [Unblock] button on the GENERAL tab and you should now be able to copy the file without error using Explorer and drag and drop or copy/paste into either an External SD card on the Fuse or to internal memory.

So, all the other talk about needing newer drivers, etc., (mine is 6/21/2006) doesn’t matter - when it’s in MTP mode.  

It’s simple.  

  1. Where did you get the file?  … and
  2. Is the file blocked by the Operating System permissions for copy.  If it is, unblock it.



Windows 7’s  Device Stage only works with a media device addressed in  MTP Mode , where the Sansa is seen as a Portable Device.

The Sansa can connect in either MTP, or MSC, _and can automatically switch modes if Auto Detect is selected on the device. _This can lead to a little confusion, as Auto Detect is ON by default, unless you manually select one mode under Settings > USB Mode.

On the computer side of this connection, you have _separate drivers for each mode.  _If something goes amiss on the PC, the device may connect in the alternate mode. A sign of  this is a device that, at one time, shows up with the Device Stage icon, and later does not. To fix this issue, manually select the desired mode, plug in, and find the Sansa using the Device Manager.

If you double click, or right-click on the device, select properties and then  uninstall. _ _After you unplug, then plug back in (give the computer about 30 seconds or so to this by waiting before plugging in again), the computer will reestablish a “partnership” with the device, in your selected mode. In the background, the PC is mating the device ID with the correct registry settings. 

Bob  :smileyvery-happy: