Calculating forever while copying

hey,i got 2G sansa clip, MSC mode.

when i drag & drop files to Music folder it’s keep calculating for ever and get stuck, so i cant add files.

got Win 7 64 bit.


What format of files are they?

How many are you trying to transfer at the same time?

format is MP3 and around 20 files at the same time…

First I’d try transferring one at a time and see if that works.

Another thing you might try in MSC mode is running Windows Error-Checking, which could fix little glitches in the internal memory.

Connect the Clip, go to Computer and right-click on the Sansa Clip disc driveletter. Properties/Tools/Error-Checking/Check Now.

And if that doesn’t help, you could try formatting the internal memory from the unit itself, but that will erase everything youhvae put in there, so make sure you have copies elsewhere.

 Settings/System Settings/Format

tried every step and still cant copy, even after formatting manually from setting menu inside the player… 

i’m desperate, there is a way to format the whole player?

thanks for the help.


i can’t belive but i changed the cable and it worked… =]:laughing:

Sometimes, the simplest measures . . . .  Congrats.   :slight_smile: