whenever I plug my player into my computer…it says that it has found new hardware but then it pops up and says that there was an error installing hardware so it may not work properly. Any suggestions on how to fix this?

does it do that on any computer you go to?

did it ever work on thsi computeR?

have you tried switching modes on the player? it can be done via settings on the player and selectings modes / usb modes

My last c240 worked on this computer …but then I had trouble with the player so they sent me a new one…and now this one i havent been able to get it to work at all and now i cant get it to turn on bc the battery went dead…not really sure what i need to do

so you cant turn it on at all?

what if you remove the battery and connect it to the computer, does it turn on?

what does it say on the screen of it if it does turn on?

what if you connect in recovery mode?Is it detected? (same as e200 recovery mode, they have instructions on the e200 faq thats posted.

whenever i turn it on when its not plugged into the computer it lights up and a pic of a battery comes on the screen and then it just goes off …but when it’s plugged into the computer it wont light up at all. whenever i plug it into the computer, it pops up that i have connected something, but then it doesnt recognize that it is a mp3 player

it also wont do anything in recovery mode

sounds like a lemon. Take it back to the place of purchase or call sandisk @ 866.sandisk to get it replaced.