C100 - frozen on a particular song

Sorry, there doesn’t appear to be a forum for the c140, but I hope you can help. Player worked fine playing downloaded music until first alkaline battery died. After replacing battery, player completely locked up, displaying last song played, still showing expired battery symbol. You can’t even turn the player off without removing the battery. It’s not the battery: I have tried several.

PC now will not even recognise the player, so I can’t even download a firmware upgrade into it. Any suggestions most welcome.

Paul Griffiths

Western Australia

Message Edited by MrSmileyFace on 10-03-2007 05:41 PM

and when it turns on its frozen on the sandisk logo?

Hi Ender

No, when I turn it on it still shows the last album I was playing, and the red battery flat indication. It is completely frozen at that screen.


have you tried contacting sandisk to replace it?

That will be my next course, but I am flying out to the US in a couple of days and thought there may have been a simple reset or something. Thanks for your interest.


Try putting the AAA battery in backwards (Positive to Negative and vice versa). Take it back out and put it back in correctly. I did this after my Sansa c140 got stuck in a loop with a bad mp3 file. It reset completely and all files were wiped, but it behaved normally again.

i´ve found the way that the player be recognized by the pc but it ask me for the DRIVER, i think that all, becouse when it detects it shows it as an unknown usb driver, please, I don´t need enymore than the driver for my C140 comes back to life !!! thanks a lot

The exact same thing just happened to me.

This is only the second time I’ve used the c140 since I bought it a couple of weeks ago, and the first time since uplaoding one playlist using Windows Media Player 11.

I shut down the c140 at the end of an mp3, and when I turned it on again a few minutes later, the display was hung up at the end of the same mp3 file, and showing a low battery icon.

No buttons worked.

The only way I could switch it off was to remove the battery!

I’m sure there must be a way to manually reset it (even Apple provides a way to reset their ipods, so I’m sure Sandisk must have a method - is there any way to persuade Sandisk to provide it?)

theres no reset that i know of, most of the other c100’s I have read about in other forums get replaced when it reaches the point that yours has.

The same problem with mine. C14o frozen with the last played song. Could you please tell me what did you do to have it recognized by the PC?

My c140 is stuck on a song also.  I have gotten the computer to recognize it – by holding the center (SELECT) button down while I plug in the USB cord; but the computer wants a driver and can’t find one on the internet when it searches for one.  Did you have any luck getting it going again?

you can email support@sandisk.com. Let them knwo your player freees and you would like to try the firmware that they have. Its not made for download on the website, but its something they have that can POSSIBLY fix frozen c100’s

My daughter bought a SanDisk c140 with her christmas money off amazon.com on 12-29-07.  Came with a year warranty.

Two or three weeks ago, she changed the battery.  When she put it back in, everything was wiped.  I’ve looked over and tried the solutions on this thread, even attempting to call Sandisk number (that they gave) for support.  I’ve emailed them twice over the last week and a half.

No responce.



Which number did you call?  Have you gotten any response?  If not, please PM me and we’ll try to get it sorted out.

I called 1-866-sandisk.

I also emailed support@sandisk.com two or three times with no response.

You’ll have a PM in your mailbox from me which says the same as above.


what happened when you called?

When I selected the Mp3 option, it gave me more choices to dial in.  I don’t believe I recall the c100 option, I think it may have been “all other” mp3 players.  When selecting that option, it referred me to the support@sandisk.com option.  (And I’ve tried emailing that address 2 or 3 times.)


o yeah, they sent the legacy products to just email support. send one of the mods a PM about no response when you email sandisk, should be able to get it addressed.

o yeah, they sent the legacy products to just email support. send one of the mods a PM about no response when you email sandisk, should be able to get it addressed.

They responded today with an auto-reply!  Yay!  (Signifying they’ll be in touch soon.)

Thanks for your attention and support with this matter!