Brightness and autoplay problems with brand new 4GB clip+

First thing I did was install the updater and apply the latest firmware (1.02.18A) - I checked my settings to confirm that.  First thing I tried to do was turn down the brightness to prolong battery life.  I reduced the “brightness bar” to almost it’s lowest setting.  The brightness doesn’t change as I move the bar down or after I confirm the change by selecting “yes”.  After a restart it is still on the factory setting, which is the brightest.

I have an 8GB clip+.  The brightness changes as I move the brightness bar down and stays there after confirming with yes.  Works perfectly.  My 4GB is not doing that.

Also, when I hook up my 4GB to my laptop (win7 x64) it does not appear in my autoplay window.  It does appear in my list of drives (windows key + E) but it does not appear as an attached device when I open my autoplay window.

Like I said my 8GB works great.  It has 1.02.15A firmware.  I’d like to install that version on my 4GB.  Where can I find older firmware builds?  I’ve googled it but the links just lead to empty folders.  If installing that version is not possible how can I at least get my 4GB to change its brightness level?  Any help is appreciated.

Also, when  hook up my 8GB it appears under “portable devices” in my list of drives in windows (widows key + E) and has a very nice icon that looks just like the player itself and is titled “Sansa clip+ 8GB”.  When I click on the drive and open the root menu the only other thing visible  besides the usual folders (music, podcasts, audiobooks etc) is a XML document named “WMPInfo”  which obviously refers to windows media player and probably has something to do with playlists.  It all looks pretty tidy.

When my 4GB is attached to my laptop it appears under “deveices with removable storage” and not “portable devices” like the 8GB.  The icon is different also, just the generic external hard drive icon titled “SANSA CLIPP” versus the actual clip+ icon of my 8GB.  The root menu of my 4GB is more clutted than the 8GB.  There are the usual files (music etc) just like with the 8GB, of course, but there are six others: “DID.bin”, “MTABLE.SYS”, “SYS-CONF.SYS” and others.  I’m assuming this part of the firmware or are some kind of necessary files but why appear on the 4GB and not the 8GB?  Can I delete these files, just so the root menu looks cleaner?  My 8GB obviously has firmware but it’s files aren’t visible in the root menu.

The player sounds OK and of course that’s what you buy it for.  But the inability to change brightness makes me wonder what else is nonfunctional and speaks to overall quality.  Disapointed so far.

Solved the icon issue, had to switch form “MTC” to “Auto detect” in USB settings.  That was the least of the issues, but yay for small victories :slight_smile:

Don’t use autodetect. Many here call it autodefect. :slight_smile: Use either MTP or MSC and stick with it.

Sandisk Clip+ firmware versions.

Seconded as to switching to MSC mode–it just works.

As to brightness, it should work.  You might try a reset (hold the power button down for 20-30 seconds) or a manual reapplication of the latest firmware–see the firmware upgrade sticky thread at the top of this forum.  

And as to earlier firmwares (but you shouldn’t need them):  check out the firmware sticky thread at the Clip forum at  

Or this one (.01.02.16) posted here on the forum. The .18 firmware is a very recent update and supposedly very minor. But there’s a possibility that whatever they did ‘broke’ the Brightness level control.

Please follow up and let us know if the Brightness level works correctly in the previous version (.16), so we can let SanDisk know there’s a problem with the .18 update.

Called Sansa tech support re brightness adjustment.  After troubleshooting was told to return the unit to Amazon since I was still in the 30-day window.  Received the replacement today (identical black 4GB model, brand new).  Out of the box (but after charging) I got the same issue - I can move the brightness control bar back and forth and confirm with the “yes” prompt at the level I want (low) but the actual brightness stays on highest setting.  Turned off player and rebooted to see if at least the brightness display bar was reflecting my choice of low setting even if the actual brightness was remaining high.  Bar refelected my choice. I tried manual install of 1.02.15 (the version that is working on my 8GB clip+), confirmed installation but it didn’t solve brightness problem.  Then 1.02.16, confirmed update, no change.  Used Sansa updater to install 1.02.18, confirmed the update, same problem. 

I compared the 4GB brightness to my 8GB clip+ (never a problem with it) which is on a low setting.  I scrolled through multiple screens in a real time side-by-side comparison.  The 4GB is noticeably brighter, so it’s not my eyes.

So, it’s two players in a row with the same problem or I’m screwing up the simplest adjust possible on a clip+ (but which I can perform correctly on the 8GB version).  Go figure.

When you go into settings and try to change the brightness, how are you confirming the change by selecting “yes”–exactly what are you doing?

Settings > system settings > brightness > brightness bar appears, I make selection then hit middle button > prompt = “confirm” > I select “yes” by clicking the middle button > player itself returns to system settings menu. 

This is exactly the same way I change settings on my 8GB.  I have changed the brightness settings on it many times without a problem.

As I said before, the 4GB is remembering the level I want.  I can power it off, reboot and check the “brightness settings level bar” and it has remembered my choice.  But the actual brightness level hasn’t changed, it stays at the brightest level.  It is recognizing my selection but simply not applying it.

Interesting note: on my 8GB clip+, as I scroll the brightness bar left/right I can see the changes in brightness as I scroll.  A very nice, common sense feature.  This does not happen on my 4GB.  Scrolling does not affect brightness.  The brightness remains static as I scoll back and forth. Then when I make a “low” selection and confirm “yes” with a middle click, it remebers the selection but the brightness stays on high.  I have put my 8GB and 4GB side by side.  Even though I have the same “brightness bar” setting on both, the 4GB is much brighter because the 8GB has applied my desired lower setting whereas the 4GB has not.

This is not a huge deal, I just want the player to work as it should.  Other settings changes I have made seem to be working OK, such as limiting the backlight to 5 seconds and putting power saver to “5 minutes” - which both involve exactly the same confirm>yes command.  The player has applied those selctions.  Not so with the brightness.

Thanks–I just wanted to confirm that you were doing what I was doing (and it works for me, including the brightness changes as I select to make it dimmer or brighter). The only extra thing I would add is, when I get ready to choose Yes to confirm the brightness change, I have to hit the player’s up button to have the Yes highlighted, to select–the No choice is highlighted by default for me. I assume that you are doing that as well (hitting the up button to highlight the Yes, before pressing the center button to select/confirm the choice).

Actually, on my 4GB “No” is the automatically/default highlighted option on the confirm screen.  I move the highlight to “yes” and confirm with middle click.  When I go back to check it has remembered the level I want but simply not applied it.

It certainly is strange that the same glitch can be on two different players.   Reason might suggest user error but I just don’t see how.  Besides, the brightness bar shows “low” (so I’m “setting” it correctly) but the brightness clearly isn’t.  Given that I can successfully change my 8GB brightness by the same procedure the problem seems to clearly lie with the player.

Is there a sloution?

Odd, indeed.  The only other thing I can think of is manually reapplying the latest firmware (even if you already have the latest)–hopefully, this would be a software glitch.  See the firmware upgrade sticky thread at the top of the forum.