Brand New Fuze v2 8Gb won't boot

As the title says, I bought a brand new fuze v2 8gb from a reputable seller on ebay. The player arrived and worked fine up until this morning. I inserted my 32gb Sandisk micro sd card. The player recognized it fine, refreshed the media fine and turned off fine. It will not connect to my pc anymore (Windows 7 Ultimate x64 or my laptop ubuntu 10.04), I’ve tried numerous usb ports on both devices. The player will also not turn on, or reset. I have tried holding the power switch for times between 10 seconds and 1 minute, tried holding the power switch and the play buttons and all other combinations given to reset the player, none of them have been sucessful. The player was fully charged when this occurred so it could not be out of the battery. I have tried all of the above with the sd card removed and verified that the sd card works in other devices so that is not the problem. Anyone got any ideas on what’s wrong here, or have I just been unlucky and got a defective player?