Battery won't charge


I bought my gf a Fuze in December 2008 and she has just explained to me that the bettery has never lasted long and that now it’s so bad that it’s unusable.  It now lasts just a few minutes, and previous to that, for last few months, it has lasted 2 hours using only the radio.

Firstly, would it still be under warranty?  Would warranty cover my issue?  How would I got about returning it considering I bought it in an airport in a foreign country?

I’ve tried looking at it myself now briefly.  I updated the firmware yesterday to the latest and greatest (hw is v1).  I then attempted to charge it using a wall socket - to be precise, an iphone charger with sansa cable instead of ipod cable.  My gf explained to me that the charging may work for a short while if you keep hitting the jog dial before the backlight timeout so I did this in order for the on-device firmware upgrade to complete.  This worked, and I stayed doing this while it refreshed the media.  After this it looked like it may actually charge up so I stopped hitting the jog dial and left it plugged in for a few hours.  The charging had clearly stopped as soon as I left it alone as no charge had registered.  I tried again but with no luck again.

She has also tried charging it using a pc running Vista (which always used to work for her).

Could this be an issue with the way I’m charging it or is this definitely a Fuze issue?

Thanks and Regards