Battery draining too fast

A full recharge, in 20 minutes it turns off. I really don’t understand what is going on.

I updated the firmware tho the program, it’s plugged on a 3.0 USB, I tried to plug it on 4 different USBs, and reseted the Sansa.

Still only shows “Critical low 0%” when I reset it, and “98%” after a full recharge. 

Can someone help me, please? Not sure what I did to ruin my mp3.

How long are you charging it for? If you are using a desktop pc are you charging it directly(not through a hub)from a rear usb port? The front usb ports often don’t have enough power. If you are using a notebook, do you plug the notebook in before connecting the player directly(not through a hub) to a usb port? On battery power many notebooks cut the power to the usb ports.

It shuts off after 20 minutes of playing? Are you charging it for at least 3 hours? Did you try using a different usb cable, or try charging it with a cell phone charger? 

Occasionally the battery meter gets out of whack. The battery meter should reset itself though if you play the player until it stops, then charge it for 3+ hours, then run it down again, then fully charge it. Forget what the battery meter says and try giving a full long charge and see how long it runs until it shuts off.

I’m on a PC, using the back USB, 3.0 (tried 4 different USBs, not only 3.0). I’ll try to use a different USB cable, I just need to find one here.

I recharged it for about 2 hours and when I took it off, it appeared “critical low, shutdown”. Then I plugged again and it states here “98%”. I changed the USB port once again (recharging for about 2 hours now). I’ll try to use it now on the gym.

But I’m really skeptical, I think it’s a battery problem, and I don’t know how to solve it here in Brazil (bought it from U.S).
Not sure where to buy another battery alone, or if it’s even possible to do it.

Thanks for another idea to change the USB cable anyway! I’ll try it later.

Additionally, how long have you had this player? Rule of thumb is that battery life degrades through wear and tear. But if you have charged it correctly, then I guess you can probably check its warranty or have it RMAed.

I have it for about 2 months or less. I think it was ending slowly, and never recharging. Now it ended for good.

It’s just not recharging. When I plug, it shows like if it was recharging, but after 3 hours when I unplug it, 10 seconds later, “critical low, shuttting down”. 

I reseted, I already changed the USB cable, I tried it on many different USBs, front, back, PC, notebook.

:\

Sounds lik a charging circuit issue or even that a lead to the battery has come undone.  Do note that you have a 1-year warranty (2 in the EU)–call SanDisk for a warranty replacement; and in the U.S., SanDisk even covers the postage both ways.  You also could go back to the seller for a replacement–Amazon has been known to do so even after the initial 30 days post-purchase (I might try this first if I had purchased from Amazon).

.

http://www.sandisk.com/about-sandisk/contact-us/

1 thng perhaps to try:  what happens if you recharge from the AC, using a USB AC adapter–same result?  If so, a player or USB cable issue. 

I brought it from eBay, unfortunately. Not used to use Amazon, never ships to Brazil and it’s very annoying. But I just checked and the Sansa Clip Zip is avaliable, I’ll check there more often then.

I sent a msg to the eBay seller (it’s a real store, with high score there, seems very trustful at least). But well, I’m probably going to have to pay for the shipping. 

Thanks a lot for your help.

And perhaps you stll might be covered by the SanDisk warranty.