Backlight off triggers an unwanted song pause, causes and "band-aid" solution?

Related to firmware version: 1.01.22

  1. Songs recorded and stored from original CD’s using Microsoft Windows Vista’s Media Player and WMA are put in an automatic pause every time the backlight turns off.

Seems independent of playing songs having been made the recording having copy protection activated or not.

I’ve tested it in a Home Premium, Service Pack 1, using the Windows Media Player that comes default with this Vista version (11.0.6001.7000) with various wma speed/formats. My Fuze player s/n is: BE0807AXWK-2GB

These formats seem to be the most proclive to fail (all share in common that are in the high quality audio profile range, minimum 128 kbps):

  • WMA with bitrate higher than 128 kbps.
  • WMA 128kbps sometimes goes to pause sometimes does a digital noise and restarts another song again, it plays 4-8 songs correctly before entering pause, but continues to get missledingly paused, warning visually before this event with a backlight turning on of backlight timer setting duration. In every way, every time changes from a song to another it puts backlight on and off the backlight timer specified seconds.
  • Windows Media Audio with variable bitrates in the 96 kbps range or higher.
  • Windows Media Pro with bitrate higher than 96 kbps.
  • Loseless Windows Media.

The pause can apparently be avoided if you change from the current song screen to a menu like the settings one, but unfortunately in this case the effect is continuously maintaing backlight on, flickering on and off every backlight timer specified seconds.

The solution I used was to convert the whole sound library to MP3 or Ogg Vorbis, I didn’t detect any problem apart from the reincidence in turning on the backlight in every song change, wich is more a maybe undesired feature wich could very niocely be a preference based option, since it is a candidate to cause premature battery exhausting when you use it mainly for digital audio music files that are not mainly classical music.

Still, in these formats, when you fast forward any song in continuous play just before ending, when the song finishes playing, the player goes again to pause mode indefinitely.

Seems by the consequences that the problem could be related to a wrong quantitative evaluation of the power changes monitoring system that induces the OS to think that a USB conector would have been aplied when what really occurs is some minor power variation due to internal process that derivate in a high deviation increase of power balance, like turning off backlight, changing to other song coming from a less CPU time consuming fast forward vs playing, etc… That would explain why it is more prone to occur in high bitrates than in lower ones, and in WMA versus other less “heuristically” massive like the good older MP3 or OGG Vorbis.

I think there is a relation between Vista suspended mode in energy feeding via USB to devices and this problem, in fact when a connection its made between the computer with Vista in suspended mode and the Fuze player, the later detects it like a source of power fed, animating the power battery icon and presenting in information page a fake 100% full, different from the animation of the battery sprite. And this results fake because no power is fed into Fuze device!.. in fact it only consumes power because maintains screen always on while connected.

This sensibility in excess I think is causing all this kind of problems related to power fed detection via USB, unproper screen turn on/off and undesired pausing of songs, all of this been affected by the different CPU usage rate between algorithms of digital audio decoding (WMA versus OGG versus MP3, in descending order of CPU usage, in its “common” implementations), and the power unstabilities that it and those interactions cause.

Going to USB hub properties in Vista’s control panel gives me 500 mA for feeding Fuze, a 4GB “pendrive” gives me 200 mA.

BTW this is what I did for converting to Ogg Vorbis in linux system (I selected USB -> MSC):

  1. Use Gnome CD extractor selecting CD quality loseless files, generates .flac files.

  2. Go to the folder and do a batch $ oggenc whatever.flac, f.e. shell script:

        for file in ls *.flac
            echo “Coding $file”
            oggenc $file

I’ve aditionally found some spanish translation related mistakes:

a) Repeat song (Repetir canción) and repeat all (Repetir todo) are inverted in spanish language version: “Repetir todo” repeats constantly the current song, and “Repetir canción” conmutes between songs and when ends all songs starts again.

b) When I connect fuze to computer in suspended mode and then power off fuze the message spanish for going suspended mode starts with word “LLendo” istead of “Yendo” wich is correct syntax for english word “Going”.

Hope this helps somebody, I tried to be precise, but no warranty I’m not missing, wrong or late in any point, of course.

Greetings, Ignacio Javier igjav

SansaFix posted awhile back what the problem was, and that Sansa is working on the issue.   His original post is found here:

Does anyone know what the status is on this?